Vi presentiamo un’interessante progetto che ci consente di includere informazioni e cover del  brano in ascolto su Spotify sul nostro tema Conky

Spotify Conky
In questi anni abbiamo presentato diversi temi per Conky, tool open source che ci consente di avere in formazioni del nostro sistema in tempo reale il tutto direttamente nel nostro desktop. Principale caratteristica di Conky è la possibilità di essere completamente personalizzabile, possiamo ad esempio includere previsioni meteo, notifiche di nuove email da leggere, particolare informazioni sul nostro pc ecc. Sul nostro tema Conky potremo anche includere informazioni sul brano in ascolto su Spotify, grazie ad un nuovo progetto realizzato dal un nostro lettore red-noise .

Spotify script for conky è un nuovo progetto open source che ci consente di avere informazioni sul brano in ascolto dal famoso servizio di musica in streaming direttamente nel nostro desktop. Caratteristica del progetto è quella di non richiedere alcuna configurazione, difatti lo script legge da dbus le informazioni della traccia in esecuzione su Spotify e ci mostra l’output delle informazioni su Conky. Oltre alla copertina, avremo informazioni dell’artista, brano e album il tutto direttamente dal nostro tema Conky preferito.

Basta scaricare Spotify script for conky da questo link, oppure dalla pagina GitHub dedicata al progetto fatto questo basta salvare la cartella spotify nella directory .conkycolors nella nostra home (ce non c’è basta crearla). A questo punto inseriamo quanto segue nel nostro tema conky (all’interno del file .conkyrc):

####################
# - MEDIA PLAYER - #
####################

${if_running spotify}${voffset -2}${font Liberation Sans:style=Bold:size=8}
${voffset -10}${goto 73}Title: 
${goto 73}${color2}${exec ~/.conkycolors/spotify/spotify_info_title }${color}
${goto 73}Artist: 
${goto 73}${color2}${exec ~/.conkycolors/spotify/spotify_info_artist }${color}
${goto 73}Album: 
${goto 73}${color2}${exec ~/.conkycolors/spotify/spotify_info_album }${color}
${voffset -18}
${exec ~/.conkycolors/spotify/spotify_album_cover}
${image ~/.conkycolors/spotify/last_album_pic.png -p 0,178 -s 60x60}
${else}${voffset -5}${color0}${font ConkyColors:size=16}G${font}${color}${voffset -6}${goto 32}Spotify: ${color2}off${color}${voffset 7}
${endif}

Possiamo aggiungere facilmente potify script for conky utilizzando Conky Manager per maggiori informazioni basta consultare il nostro articolo dedicato.

Ringrazio il nostro lettore red-noise per la segnalazione.

  • RobertoTrynight

    A me su Chakra via bundle non si apre…

    • Simone

      Confermo. Io credo di aver risolto disinstallando la versione del bundle, installando la versione versione dei repo, reinstallando la versione del bundle e disinstallando quella dei repo. Non chiedermi perché, ma per ora sembra funzionare 😀

      • Problemi con le dipendenze che ti vengono correttamente installato con la versione dei repo mentre nella bundle non sono state incluse 😛

  • Bernardo Mattiucci

    Per 11.10 64 bit, niente?

  • Roberto Moretti

    la ricerca degli utenti è ora uguale a quella per la versione di winzozz o è ancora il vecchio stile dove si può cercare tramite città e/o età e/o sesso???

  • PatrizioTufarolo

    Anche con Arch/Chakra 64bit e derivate stesso problema (bisogna compilare un sacco di roba tramite AUR), tutto per via delle librerie Qt Webkit usate da Microsoft nella schermata di apertura di Skype che non esistono in versione multilib.

  • Pietro

    su Opensuse mi va skype-4.1.0.20-suse.i586.rpm e mi va senza problemi nella OpenSuse 64 bit tumbleweed.

  • Fabio

    Posto che per Squeeze pare non ci sia, pensa te se devo fare un “force-architecture” per installare quello che loro chiamano un “multiarch”… Microsoft: fatti, non pugnette! 😉

  • Claudio

    Scusate, io ho debian wheezy. Quando tento di installare la nuova versione di skype, ho il seguenti messaggio pur avendo disinstallato la versione precedente:
    # dpkg -i –force-architecture skype-debian_4.1.0.20-1_i386.deb
    dpkg: attenzione: viene ignorato il problema poiché è usata l’opzione –force:
    l’architettura del pacchetto (i386) non corrisponde a quella del sistema (amd64)
    Selezionato il pacchetto skype non precedentemente selezionato.
    (Lettura del database… 165569 file e directory attualmente installati.)
    Estrazione di skype (da skype-debian_4.1.0.20-1_i386.deb)…
    dpkg: problemi con le dipendenze impediscono la configurazione di skype:
    skype dipende da libasound2 (>= 1.0.16).
    skype dipende da libc6 (>= 2.3.6-6~).
    skype dipende da libc6 (>= 2.7).
    skype dipende da libgcc1 (>= 1:4.1.1).
    skype dipende da libqt4-dbus (>= 4:4.5.3).
    skype dipende da libqt4-network (>= 4:4.8.0).
    skype dipende da libqt4-xml (>= 4:4.5.3).
    skype dipende da libqtcore4 (>= 4:4.7.0~beta1).
    skype dipende da libqtgui4 (>= 4:4.8.0).
    skype dipende da libqtwebkit4 (>= 2.1.0~2011week13).
    skype dipende da libstdc++6 (>= 4.6).
    skype dipende da libx11-6.
    skype dipende da libxext6.
    skype dipende da libxss1.
    skype dipende da libxv1.
    skype dipende da libssl1.0.0.

    dpkg: errore nell’elaborare skype (–install):
    problemi con le dipendenze – lasciato non configurato
    Si sono verificati degli errori nell’elaborazione:
    skype

    Come mi devo comportare?
    Grazie

  • Claudio

    Scusate, io ho debian wheezy. Ho cercato di installare l’ultima versione di skype cancellando prima la precedente (che va benissimo) ma ho ottenuto il seguente messaggio:
    # dpkg -i –force-architecture skype-debian_4.1.0.20-1_i386.deb
    dpkg: attenzione: viene ignorato il problema poiché è usata l’opzione –force:
    l’architettura del pacchetto (i386) non corrisponde a quella del sistema (amd64)
    Selezionato il pacchetto skype non precedentemente selezionato.
    (Lettura del database… 165569 file e directory attualmente installati.)
    Estrazione di skype (da skype-debian_4.1.0.20-1_i386.deb)…
    dpkg: problemi con le dipendenze impediscono la configurazione di skype:
    skype dipende da libasound2 (>= 1.0.16).
    skype dipende da libc6 (>= 2.3.6-6~).
    skype dipende da libc6 (>= 2.7).
    skype dipende da libgcc1 (>= 1:4.1.1).
    skype dipende da libqt4-dbus (>= 4:4.5.3).
    skype dipende da libqt4-network (>= 4:4.8.0).
    skype dipende da libqt4-xml (>= 4:4.5.3).
    skype dipende da libqtcore4 (>= 4:4.7.0~beta1).
    skype dipende da libqtgui4 (>= 4:4.8.0).
    skype dipende da libqtwebkit4 (>= 2.1.0~2011week13).
    skype dipende da libstdc++6 (>= 4.6).
    skype dipende da # dpkg -i –force-architecture skype-debian_4.1.0.20-1_i386.deb
    dpkg: attenzione: viene ignorato il problema poiché è usata l’opzione –force:
    l’architettura del pacchetto (i386) non corrisponde a quella del sistema (amd64)
    Selezionato il pacchetto skype non precedentemente selezionato.
    (Lettura del database… 165569 file e directory attualmente installati.)
    Estrazione di skype (da skype-debian_4.1.0.20-1_i386.deb)…
    dpkg: problemi con le dipendenze impediscono la configurazione di skype:
    skype dipende da libasound2 (>= 1.0.16).
    skype dipende da libc6 (>= 2.3.6-6~).
    skype dipende da libc6 (>= 2.7).
    skype dipende da libgcc1 (>= 1:4.1.1).
    skype dipende da libqt4-dbus (>= 4:4.5.3).
    skype dipende da libqt4-network (>= 4:4.8.0).
    skype dipende da libqt4-xml (>= 4:4.5.3).
    skype dipende da libqtcore4 (>= 4:4.7.0~beta1).
    skype dipende da libqtgui4 (>= 4:4.8.0).
    skype dipende da libqtwebkit4 (>= 2.1.0~2011week13).
    skype dipende da libstdc++6 (>= 4.6).
    skype dipende da libx11-6.
    skype dipende da libxext6.
    skype dipende da libxss1.
    skype dipende da libxv1.
    skype dipende da libssl1.0.0.

    dpkg: errore nell’elaborare skype (–install):
    problemi con le dipendenze – lasciato non configurato
    Si sono verificati degli errori nell’elaborazione:
    skype

    dpkg: errore nell’elaborare skype (–install):
    problemi con le dipendenze – lasciato non configurato
    Si sono verificati degli errori nell’elaborazione:
    skype

    Queste librerie, però risultano essere installate. Come dovrei comportarmi?

    Grazie

  • Pietro Bortoletto

    Per Fedora avete qualche idea? Dopo l’aggiornamento mi da il seguente errore “skype: symbol lookup error: skype: undefined symbol: _ZN17QSslConfiguration12setSslOptionEN4QSsl9SslOptionEb

  • Andrea

    salve!

    sono del tutto ignorante ma nel mio caso (ubuntu 12.04 64bit) credo sia stato necessario installare prima ia32-libs.

    o perlomeno cosi ha funzionato.

  • Patrick Grioni

    io non ho avuto problemi con Ubuntu 64 bit sinceramente

  • a me continua a nn funzionare

  • a me continua a nn funzionare

  • a parte ke sono nuovissimo e probabilmente nn so come si fa..
    qualke aiuto?

    • maniuz

      dai qualche informazione utile. che disto utilizzi tanto per cominciare?

  • a parte ke sono nuovissimo e probabilmente nn so come si fa..
    qualke aiuto?

  • Marco

    🙂 very good, ubuntu 12.04 64bit

  • TuxJ

    Io mi ritrovo un .deb della versione 4.0.0.8 per architetture amd64, se installo quello anzichè del nuovo 4.1? Almeno quello vecchio era a 64bit e non sono costretto ad installare una versione a 32bit ke poi andrà emulata (e occuparmi il doppio della ram quando è in esecuzione)

  • Marco Vicini

    Ho seguito le istruzioni e ho installato il programma ma dopo alcuni secondi di esecuzione si chiude improssivamente, io ho L’ultimo Ubuntu a 64bit

  • ange98

    Come si chiama il nome di quel tema di gs?

  • Jack O’Malley

    Carino ma niente di eclatante, ricordo che 3/4 anni fa sul forum di Ubuntu Italia nel thread “Posta il tuo .conkyrc & .png” un utente aveva fatto un conky che reperiva e mostrava anche il testo delle canzoni in ascolto da Rithmbox, Banshee e simili oltre a mostrare la cover e i dati del brano.

    • Ciao Jack! Per i riproduttori musicali offline, l’opzione di visualizzazione di copertina, informazioni brano, artista, album e simili è già integrata nelle funzionalità di conky-colors.
      (invece per spotify si è proposto questo script).

  • Grazie per la condivisione, @Lffl cercherò di contribuire sempre più a progetti così.

    @ange98:disqus il tema per gs è Zuikitwo lo trovi ovunque.
    repo ufficiali http://goo.gl/AojV9V, lffl http://goo.gl/pJDS8X.
    Gnome-Looks, DeviantArt…

  • Damiano Ansaloni

    Grazie 1000, mi si era piantato Skype. Questo è l’unico articolo che ha risolto il mio problema (era il 4° che provavo senza successo). Grazie e Grande!

  • Nino

    Non ho ben capito. Ho scaricato il tar.gz, ho estratto la cartella Spotify nella nuova directory “.conkycolors” da me creata nella Home, fin qui nulla di strano. Ma con il file conkyrc presente nel tar cosa devo fare?
    Se copio anch’esso della directory conkycolors e poi lo modifico come sopra riportato il conkymanager nonostante io abbia inserito la cartella .conkycolors tra le sorgenti, non mi trova il widget. Lo stesso accade se salvo il file conkycr modificato all’interno della cartella Spotify all’interno della directory .conkycolors

No more articles