Nvidia ha recentemente rilasciato i nuovi driver 343.36 per Linux, importante aggiornamento che include diverse migliorie. Ecco come installarli.

Nvidia
Negli ultimi anni abbiamo sono approdate numerose ottimizzazioni riguardanti il supporto hardware in Linux da parte di AMD e Nvidia. Proprio Nvidia sta portando numerose migliorie in Linux (grazie anche alla collaborazione con Valve), con performance grafiche ormai simili (ed in alcuni casi superiori a Microsoft Windows). Da Nvidia sono approdati nei giorni scorsi i nuovi driver 343.36 per Linux, aggiornamento che oltre a vari correzioni include soprattutto un miglior supporto per le nuove versioni del Kernel Linux.

Nvidia 343.36 per Linux include anche il supporto per il server grafico X.org 1.17 oltre ad includere la nuova opzione “UseSysmemPixmapAccel” e “AllowIndirectGLXProtocol” nelle configurazioni / preferenze di Nvidia. I developer Nvidia con il driver 343.36 hanno corretto diversi bug riguardanti UnrealEngine 4 e risolto alcuni problemi riscontrati nell’avvio di applicazioni e game 32 Bit in sistemi 64 Bit.

In questa pagina troverete il changelog completo riguardante Nvidia 343.36 per Linux, inoltre troverete il download dell’installer.

Per li utenti Ubuntu è possibile installare i nuovi driver Nvidia 343.36 digitando da terminale:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-343

al termine dell’installazione / aggiornamento dovremo riavviare la distribuzione.

  • xmattjus

    Quando do il comando sudo dpkg -i mi da errore e non mi installa il programma.. Con il software center installa il pacchetto ma dopo non parte.. Peccato, avrei voluto provarlo!

    • dpkg -i ti da errore perchè mancano le dipendenze che installi con install -f successivamente

      • Oreste Scalzone

        dopo il dpkg -i ci vuole *.deb
        dunque dpkg -i *.deb

        • errore mio ho corretto l’articolo
          grazie x la segnalazione

          • xmattjus

            Grazie, proverò stasera..

  • Gianluca Venturi

    a me non rileva driver proprietari
    Cioè, sto usando quelli di default su mint
    ma se volessi aggiornare con quelli proprietari, il gestore dei drivers mi dice che non ne trova..
    wigsoo@wigsoo-desktop ~ $ lspci | grep VGA
    05:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV730 XT [Radeon HD 4670]
    wigsoo@wigsoo-desktop ~ $

    • per quella scheda video è terminato il supporto alla versione 12.04(se non ricordo male)

      • Gianluca Venturi

        Grazie Luigi
        Quindi i drivers non proprietari sono migliori?
        cioè, non installa nemmeno quelli vecchi…..
        ?

        • guarda non so risponderti con esattezza perchè uso i driver open da un po. Però:
          – se usi una versione di ubuntu superiore alla 12.04 (o derivate, quindi anche mint),sono quasi sicuro che sarai in grado di installare i vecchi driver perchè non sono più compatibili con la nuova versione di Xorg delle distribuzioni seccessive ad ubuntu 12.04;
          – se usi ubuntu 12.04 (o derivate) credo che puoi installare gli ultimi driver supportati da ati/amd. cercando su google “cchtml” trovi il wiki NON ufficiale di ati/amd dove trovi tutte le informazioni e i comandi per installare i driver

  • vito mancino

    Ciao a tutti l’installazione viene completata ma poi non si avvia il programma anche lanciando da terminale non si avvia senza darmi errori su ubuntu 13.04 64 bit

    • se non si avvia dovrebbe dare errori
      devi avviarla da root da terminale
      ossia dai
      sudo driver-manager

      • vito mancino

        fatto si avvia solo da terminale,ma se voglio comi si disinstalla??

        • sudo apt-get remove drive-manager

          • Mirco

            sudo apt-get remove mintdrivers
            a me funziona con questo 😉

  • CF

    con la 12.04 LTS non funziona. Si blocca l’installazione:

    dpkg: problemi con le dipendenze impediscono la configurazione di mintdrivers:
    mintdrivers dipende da ubuntu-drivers-common, ma:
    Il pacchetto ubuntu-drivers-common non è installato.
    dpkg: errore nell’elaborare mintdrivers (–install):
    problemi con le dipendenze – lasciato non configurato

    • difatti è per ubu 13.04 quindi sulla 12.04 non si può installare

  • Ivan Notarstefano

    io, con ubuntu 13.04 ho seguito la guida, ma il programma non parte, se provo a farlo partire da terminale mi da questo errore:

    Traceback (most recent call last):
    File “/usr/bin/driver-manager”, line 17, in
    command = “%s %s” % (launcher, tool)
    NameError: name ‘launcher’ is not defined

    penso di dover cambiare la scritta launcher tra parentesi, ma non solo troppo sicuro e non vorrei compromettere il tutto

  • mpare

    è solo per i driver video o anche ad esempio quelli dell’adattatore wifi?

  • ukira

    io, con ubuntu 13.04 ho seguito la guida, ma il programma non parte, se provo a farlo partire da terminale mi da questo errore:

    Traceback (most recent call last):
    File “/usr/bin/driver-manager”, line 17, in
    command = “%s %s” % (launcher, tool)
    NameError: name ‘launcher’ is not defined

  • ukira

    ?????????????????????????????????????????

  • ukira

    Una soluzione?

  • Andrea Jörmungandr

    Anche a me dà errore all’avvio dell’applicazione.

    ” jormungandr@xw8200:~$ sudo driver-manager
    Traceback (most recent call last):
    File “/usr/bin/driver-manager”, line 17, in
    command = “%s %s” % (launcher, tool)
    NameError: name ‘launcher’ is not defined ”

    Di python non capisco una cippa. Qualcuno ha una soluzione? :/

  • francesco

    a me ancora non va,dopo l istallazione faccio partire il programma,mi chiede la pass e poi non fa più nulla..soluzioni?ho ubuntu 13.04 64bit su un acer aspire 5745g

  • Ogni volta il rischio che Ubuntu salta è altissimo… speriamo bene…

    • TopoRuggente

      Non me ne parlare, da idiota ho installato i 343 senza leggere le specifiche e quindi sapere che il supporto per la GTS 250 che monto in quel PC era stato lasciato nella serie 340 dei driver.

      • loki

        stessa cosa è successa con i normali aggiornamenti ad amici che hanno voluto mettere arch e non sapevano questa cosa…

        • TopoRuggente

          Infatti pure io su arch.

          Sarebbe interessante (ci sto pensando da allora) a poter estendere la gestione delle dipendenze di pacman anche all hardware (appoggiandosi magari a lspci e lsusb), se hai l’hardware tutto bene, altrimenti almeno un “warning”.

      • quindi non c’era nessun tipo di warning che segnalava che le gpu serie 200 e precedenti non erano più supportate dai nuovi driver??

        • TopoRuggente

          Non che io abbia visto, poi da qualche parte ho trovato il consiglio
          “Vai sul sito di nvidia prova a scaricare i driver e segnati qual’è la versione” …. ovviamente 340

  • eMcE

    And what about 346 version? There is also in xorg-edgers ppa.

    • Guest

      Yep,I think you can find it there

    • ZaccariaF

      Yep, I think you can find it there.

      • eMcE

        Yes, they are there some longest time.. and I have them installed already. I just asked out of curiosity 🙂

    • SPQR

      Visto che leggi gli articoli in italiano (e, a quanto pare, lo capisci), potresti pure sforzarti di commentare nella stessa lingua.

      • Carlo

        Studia te l’inglese, italiano medio.

        • concordo sul fatto che nel 2014 l’inglese bisogna saperlo.
          però se tu rispondi in questo modo a SPQR, allora secondo me è sbagliato, cioè è stato eMcE a scrivere in un blog italiano in inglese, quindi eventualmente chi deve fare lo sforzo di scrivere nell’altra lingua è proprio lui.
          poi certo SPQR poteva anche rispondergli o ignorarlo.

          • ange98

            Non credo che gli sarebbe costato nulla scrivere in inglese… Cioè in fondo un minimo di inglese lo conosciamo tutti, se invece lui si fa tradurre la frase dalla sua lingua all’italiano da Google Traduttore potrebbe anche venire totalmente storpiata.

          • quello è vero, in fondo è più facile leggere e capire piuttosto che scrivere.
            infatti ho detto che poteva anche rispondergli o tutto al più ignorarlo.
            però dire addirittura “studia te l’inglese”… insomma…

      • eMcE

        What? Englisch please!

    • 346 version still in beta branch.
      when will be stable we can see this version on repositories

      • eMcE

        346 from >>xorg-edgers repo<< was no in beta. Those from nvidia's http://ftp.. Yeap.. was beta version. There is a difference 😉

        • but are in beta on nvidia site

          • eMcE

            Who cares about f***n nvidia site?! Post is about xorg-edgers ppa.
            eeeehhh.. reading with understanding is a bless.

          • and then as you do so sarcastic, next time also avoids writing
            bye

          • eMcE

            Sarcastic? No.. Just sain..
            Btw.. this discussion is useless. Im talkin about ppa, Youre about other site. so.. eot.

  • Orazio77

    Ciao a me ha installato i 346.22 su ubuntu 14.04

    • mr01

      E’ normale, i 346.16 stavano da un mese e passa (era un esempio) , ma sono ramo dev, i 343 sono per gli amanti del ramo “stable”

    • forse volevi dire 346.16, visto che i 346.22 non ci sono (per lo meno per ora)

      • Orazio77

        E su kubuntu 14.04 ha installato i 340.58
        Come mai? Boo

        • forse hai una scheda video della serie 200 o precedente?? perchè per queste schede gli ultimi driver disponibili sono proprio i 340.. i successivi non supportano più queste schede

          • mil

            346.35 disponibili da ieri mi pare.

          • è appena arrivato l’aggiornamento su archlinux, domani li provo

        • Mr01

          Hai i ppa ufficiali? Se non hai i ppa messi da te è normale, i repo ubuntu sono meno recenti

      • Mr01

        Ci sono… o almeno per 15.04 si

  • aspetto con ansia i 346.x visto che porteranno notevoli miglioramenti di performance nel frame buffer object delle applicazioni opengl

    • Killthepenguin

      Aspetta e spera, pinguinazzo, dal profondo della cantina. Io intanto mi godo Windows, dove funziona sempre tutto.

      • ZaccariaF

        dove funziona sempre tutto.

        Con i dovuti driver…se esistenti per la versione Win in uso,e non in conflitto, sia HW che col sistema(essendo prodotti da terze parti, non coordinate con lo sviluppo di Win stesso );allora si può dire che funzioni tutto,comunque mi sembra un po’ azzardato quel che scrivi.

      • ahahahaha sei patetico..
        ho forse parlato di malfunzionamento?? te mi sa che ti sei fatto accecare dalla microsoft visto che neanche sai leggere i commenti.

        anzi io uso linux proprio perchè tutto funziona meglio di windows, ogni volta che riuso windows 7 sono frustato nel vedere le finestre che come metti un po sottosforzo il PC iniziano a dire “X non risponde”, se questo è funzionare…..
        poi vogliamo parlare dell’installazione dei driver?? inspiegabilmente su windows ci vogliono molti minuti… su linux l’installazione dei software richiede pochi secondi….

        poi è vero i giochi fino ad ora girano meglio su windows… e per fortuna… ci mancherebbe che era il contrario visto che sono stati tutti creati per windows e solo successivamente sono stati CONVERTITI per linux.

        comunque ricordo anni fa quando ancora usavo wine e ancora avevo un PC abbastanza deboluccio, i giochi con wine giravano meglio che su windows vista, e pure erano giochi nativi windows e wine non era evoluto come ora…. ehh sii windows funziona proprio bene.

        ora torna a giocare con le mattonelle di modernUI e a perdere minuti per installare software… per non parlare poi della gestione degli aggiornamenti altrimenti poi non mi fermo più

      • TopoRuggente

        Ha pienamente ragione esistono migliaia di virus, trojan e malware che in ambiente Windows funzionano benissimo e in ambiente Linux non riusciremo mai a farli girare …

  • Windows Slavery For Life

    Ma cosa servono i driver delle schede video su uculu se tanto poi non ci sono ghiochi SERI ,cioé AAA,da giocareh?
    Certo che son resistivi a farli mica lavorano per niente nelle foundry!

    • mr01

      Io gioco benissimo su “uculu” meglio di quella scagazzata di winmerd che usi te.
      Ci sarà un motivo se un intero gioco winmerd-based su Linux mi da più fps.

    • Ostia il mitico Zeb… ma guarda che incontri che si fanno…:D

    • Andrea

      Sei proprio un pessimo troll

    • Jacopo Ben Quatrini

      e da quando i giochi AAA sarebbero giochi seri ? LOL

    • gia il nick spiega quanto puoi essere intelligente “windows schiavitù per la vita”
      a parte che i giochi AAA ci sono e altri sono in arrivo, ma poi le schede grafiche non servono solo a giocare, genio

  • Ermy_sti

    ma qualcuno ha problemi di refresh orrizzontali o tearing? non sono mai riuscito a risolverli. I problemi ci sono a prescindere dalla distro sia su amd che nvidia

    • loki

      nvidia (niente optimus) + unity e non ho tearing. dovrebbe essere a posto anche con gnome e cambiando qualche opzione con kde

      • Ermy_sti

        io con xubuntu non sono mai riuscito a sistemarlo, quando usavo ubuntu era un poco meglio ma non sono mai riuscito a risolvere completamente…l’unica distribuzione che non mi da problemi è windows e la cosa è molto triste

    • anche a me ogni tanto sfarfallano..incredibile…:

      • Ermy_sti

        infatti ogni volta che si parla di linux come media center rabbrividisco

        • perchè rabbrividisci?? io non ho mai alcun tearing ne con nvidia ne con intel e amd.
          inoltre i mediacenter con linux sono perfetti.. e guardacaso se compri un hard disk multimediale, avrà quasi sicuramente un kernel linux, quindi io rabbrivisico più quando vedo un mediacenter windows, che solo per l’OS ti serve quasi il doppio della potenza
          per lo meno io parlo di xfce visto che è l’unico de che uso. inoltre vorrei aggiungere che ho disabilitato il vsync quindi anche senza questo non ho comunque tearing

          • Ermy_sti

            io ne ho provate di tutti i colori ma non sono mai riuscito a risolvere questo problema forse legato ai bassi hz della tv (60) in qualsiasi caso mai riuscito a risolverli e leggendo in rete pare che ce ne siano una marea di persone con questi problemi e non dipendono dalla distribuzione e soprattutto non sono risolvibili se non passando a windows…e cmq vuoi paragonare i filtri ffdshow presenti solo su windows? per linux se vuoi utilizzare qualche filtro devi per forza usare vlc che non è paragonabile a ffdshow.
            Per curiosità come hai disabilitato il vsync?

          • su xfce si può abilitare/disabilitare dalle impostazioni del compositor, ma tale funzionalità è stata implementata solo nella versione 4.11 di xfwm (ancora in fase di sviluppo, ma la uso da mesi ed è davvero stabile, mai avuto un problema)

          • Ermy_sti

            Magari cerco se esiste un PPA stabile per xfce su 14.04

          • Ermy_sti

            Risolto!! Il problema era il compositor di xfce

            1. disabilitare il compositor di xfce

            2. sudo apt-add-repository ppa:richardgv/compton
            sudo apt-get update
            sudo apt-get install compton

            3. all’avvio inserire il comando: compton –backend glx –paint-on-overlay –vsync opengl-swc

          • anche io uso compton, lo trovo davvero bello e performante

          • Ermy_sti

            le prestazioni mi andavano bene anche prima il problema era il tearing insopportabile. Adesso che ho risolto sto esultando ormai da 5 ore 😀

          • sisi come prestazioni anche xfwm è ottimo, direi che è molto vicino a compton.
            però compton a suo vantaggio ha una maggiore personalizzazione e qualche effettino in più

      • Ermy_sti

        Risolto!!! Il problema era il compositor di xfce

        1. disabilitare il compositor di xfce

        2. sudo apt-add-repository ppa:richardgv/compton

        sudo apt-get update

        sudo apt-get install compton

        3. all’avvio inserire il comando: compton –backend glx –paint-on-overlay –vsync opengl-swc

  • Leonardo

    provati i 346.36 su Arch x64 una catatrofe, ho dovuto regredire, riconfigurare xorg (le pene dell’inferno per far rifunzionare optimus)

No more articles