I developer Mozilla hanno introdotto il supporto per il nuovo plugin per OpenH264, ecco come attivarlo nella versione in fase di sviluppo.

Firefox plugin OpenH264
Son passati quasi 10 mesi dall’annuncio di Cisco di voler rendere “open” il codec H.264 che verrà rilasciato con licenza BSD e sviluppato all’interno del progetto OpenH264. Grazie ad OpenH264 sarà possibile riprodurre contenuti multimediali senza alcun plugin di terze parti, per questo motivo già molti sviluppatori stanno lavorando per integrarne supporto nei propri browser ed applicazioni. Mozilla ha già iniziato a lavorare nell’introdurre il plugin per OpenH264 integrandolo nella versione in fase di sviluppo Nightly, migliorando notevolmente il supporto per WebRTC per effettuare ad esempio chiamate / video chiamate senza account o senza alcun plugin di terze parti.

Il plugin per OpenH264 in Firefox Nightly è disattivato di default, potremo attivarlo con molta facilità dalle impostazioni avanzate del browser open source di Mozilla.
Per prima cosa scarichiamo Firefox Nightly in italiano per Linux, Windows e Mac da questa pagina, basta estrarre il file e dare un doppio click sul file firefox per avviare il browser.
Una volta avviato Firefox Nightly dovremo digitare nella barra degli indirizzi about:config e confermare l’accesso, successivamente digitiamo nella barra di ricerca h264 e impostiamo in true il risultato media.peerconnection.video.h264_enabled come da immagine in basso e riavviamo il browser.

Firefox: attivare il plugin OpenH264

Al riavvio basta accedere alla sezione dedicata agli add-on e plugin del browser e avremo il plugin OpenH264.
Ricordo che per Ubuntu e derivate è possibile attivare il supporto per la riproduzione di contenuti multimediali in H.264 in Firefox semplicemente seguendo questa guida.

Home OpenH264

  • Dario · 753 a.C. .

    Ottimo, la setto per perché uando raggiunge il livello critico di batteria al posto dello spegnimento…

    Può causare problemi la guida o fila tutto liscio al 100percento?

    • istanza

      Ringrazio per la guida: ora ibernazione funziona a dovere…
      NON funziona la sospensione (Asus UX32VD)… ma si cercherà…

  • Scusate, ma voi siete riusciti ad installare ubuntu 13.04?

    • Erostrato

      Io sì, installata la versione 64 bit, su pc da 4 giga con processore intel core duo, e scheda grafica nvidia gforce 9600. Funziona tutto piuttosto bene e fino ad ora non ho avuto nessun grosso problema. Anzi, mi funziona molto meglio della 12.10 che avevo proprio cancellato per l’infinità di problemi che mi dava.

      • Erostrato

        Devo aggiungere però che ho provato ora l’ibernazione e non mi funziona, così come la sospensione. Peccato perché la uso spesso su elementary os, dove va egregiamente.

      • Ho scoperto il motivo perché non riuscivo a fare l’installazione. All’avvio del cd, tramite il tasto F2 selezionavo la lingua italiana, e così facendo alla schermata successiva il processo si bloccava. Ho provato quindi a lasciare la lingua inglese e tutto è filato liscio come l’olio.

  • maniuz

    occorre ricordare che per ibernare il pc serve avere un’area di swap di almeno 1 GB 😉

  • Simone

    Ciao acer aspire 5720 non va né sospensione né ibernazione, su mint nadia nessun problema (avuto fino a ieri!

  • Ciao, vorrei porvi una domanda: quale sarebbe il discriminante tra un pc che supporta l’ibernazione e uno che non lo supporta?

    L’ibernazione dovrebbe essere semplicemente una copia della RAM all’interno dell’area di swap creata, pertanto non vedo per qual motivo alcuni pc non dovrebbero permetterlo! (visto che il kernel effettua questa operazione ogni qualvolta lo spazio libero sulla RAM non è sufficiente per le applicazioni…)

    Comunque sia, sul mio PC dando il comando sudo pm-hibernate ottengo una schermata nera per qualche secondo, dopo di che torna alla scrivania come se nulla fosse successo e il comando viene interrotto senza nessun tipo di output.

    Ho un ASUS S56C con HDD ibrido SSD, Ubuntu 13.04, 4GB di RAM e 5GB di partizione swap.

    Grazie, Fabio

    EDIT: Dando il comando sudo pm-hibernate il pc copia PARTE della ram all’interno dell’area di swap (circa 600MB su 1.5GB), ma non termina la copia e non effettua lo shutdown.

    • carlo coppa

      Se può essere utile avevo lo stesso problema, ma mi è bastato aumentare la partizione swap per risolvere, infatti ora funziona, forse la swap non è sufficientemente grande per contenere i dati di ibernazione e quando si accorge che non ci stanno, non si attiva.

  • Raffaele Birkhoff Sanseverino

    io uso sempre la sospensione. Cmq i comandi della guida funzionano . A me si iberna ma siccome durante la giornata per lavoro (programmatore) lo riaccendo parecchie volte la sopsensione va più che bn 😉

  • io ancora non mi capacito del perchè il mio ff non abbia supporto h264 anche se su arch ho installato tutti i possibili gstreamer e gst D:

    • da me su arch con firefox 30 funziona h264, infatti su youtube ormai non uso più flashplayer ma solo html5 anche per i video con pubblicità
      hai settato in “about:config” la voce “media.gstreamer.enabled” a “true”

      • -.-

        idem per me su ubuntu 14.04: da quando ff si è aggiornato alla versione 30, non ho il minimo problema

      • Dimenticavo di specificare che sono su ff 24 (icecat)
        ad ogni modo ha funzionato!

  • jboss

    youtube li apre alla perfezione, invece altri siti,alcuni non li apre proprio ed altri li apre ma il video va a scatti

  • Massimo Strangio

    Da Firefox 30 in su viene utilizzato gstreamer1.0, quindi la guida per attivare H.264 in Firefox su Ubuntu 14.04 non è più necessaria, basta aggiornare.

No more articles