Fresh Player Plugin è un nuovo progetto che ci consente di utilizzare la versione aggiornata di Adobe Flash Player inclusa in Google Chrome, anche in Mozilla Firefox e altri browser Linux.

Fresh Player Plugin in Firefox su Ubuntu Linux
Adobe da più di due anni ha deciso di abbandonare lo sviluppo di Flash Player in Linux, mantenendo 11.2 (che sarà disponibile ancora per diversi anni). Per risolvere questo problema, Google ha deciso di avviare il progetto Pepper Plugin, delle API che consentono di avere la versione aggiornata di Adobe Flash Player anche in Linux. Attraverso Pepper Flash Player è possibile includere la versione aggiornata di Flash Player anche in Chromium e ora, attraverso il progetto Fresh Player Plugin, potremo averla anche in Mozilla Firefox, Midori, Rekonq e altri browser Linux.

Fresh Player Plugin è un nuovo progetto che ci consente quindi di poter avere sempre aggiornata la versione di Adobe Flash Player in qualsiasi browser Linux, grazie al progetto Pepper Flash Player. Il progetto Fresh Player Plugin è ancora in fase di sviluppo e attualmente include ancora diversi bug, lo sviluppo poterà molto presto una maggiore stabilità e soprattutto una facile installazione nelle principali distribuzioni Linux.

Fresh Player Plugin - versione Adobe Flash Player

Per poter installare / testare Fresh Player Plugin in Ubuntu Linux e derivate per prima cosa dovremo installare Pepper Flash Player consultando questa nostra guida dedicata.
A questo punto avviamo il nostro file manager da Root per farlo basta digitare da terminale sudo seguito dal nome del file manager, esempio per Nautilus basta digitare:

sudo nautilus

e andiamo nella directory /usr/lib/pepflashplugin-installer/ e clicchiamo sul file libpepflashplayer.so con il tasto destro del mouse e diamo Crea Collegamento. Verrà creato un file denominato Collegamento a libpepflashplayer.so che dovremo salvare con il nome di libpepflashplayer.so in /opt/google/chrome/PepperFlash/libpepflashplayer.so (se non ci sono le directory indicate basta crearle).

Ora possiamo scaricare e compilare Fresh Player Plugin, per prima cosa installiamo alcune dipendenze richieste per la compilazione digitando da terminale:

sudo apt-get install build-essential git cmake pkg-config libglib2.0-dev libasound2-dev libx11-dev libgl1-mesa-dev liburiparser-dev libcairo2-dev libpango1.0-dev libpangocairo-1.0-0 libpangoft2-1.0-0 libfreetype6-dev libgtk2.0-dev

Ed ora scarichiamo e compiliamo Fresh Player Plugin digitando da terminale:

cd
git clone https://github.com/i-rinat/freshplayerplugin.git
cd freshplayerplugin && mkdir build
cd build
cmake ..
make

spostiamo il file libfreshwrapper.so creato nella cartella bin nella home e digitiamo da terminale:

sudo mv libfreshwrapper.so /usr/lib/mozilla/plugins/libfreshwrapper.so

Ora possiamo avviare il nostro Mozilla Firefox ed avremo attivo il nuovo Fresh Player Plugin per verificarlo basta accedere in questa pagina del portale Adobe dedicata alla verifica della versione di Flash Player inclusa nel nostro browser.

Fresh Player Plugin è disponibile anche per Arch Linux e derivate attraverso AUR. (thanks Dea1993)

Ringrazio il blog WebUpd8 fonte della guida

Home Fresh Player Plugin

  • per archlinux c’è il pacchetto su AUR ma tra le dipendenze richiede google chrome

    • matteo

      che senso ha scaricare e scompilare chrome solo per avere il pepper flash?

      • penso che lo prenda da li, quando l’ho installato da AUR mi ha scaricato chrome ma non lo ha installato (se non sbaglio) e poi mi ha continuato la compilazione di fresh player, comunque sia non mi importa di flash 13.x tanto la 11.2 per quel che ne faccio io va egregiamente, quindi mi accontento senza dovermi installare 5-6 dipendenze e sprecare tempo inutilmente per ricompilarlo ad ogni aggiornamento

  • Alex

    Mi avete aperto un mondo. Grazie! 🙂

  • Renato Giordanelli

    Per Firefox?

  • duccio

    mi chiedo costava tanto ad adobe non abbandonare lo sviluppo di flash per linux?

  • David

    Problema: L’audio arriva in ritardo rispetto al video. Che posso fare?
    Ciao e grazie.
    David

    • ge+

      è una early alpha ancora, quindi bug a go go.

      usa il plugin solo a scopo di test,almeno fino alle ultime beta

      • David

        Ok. Ho provato a disabilitare dai plugin di Firefox la versione 13 ed a lasciare attiva la 11. Però non funzica. Come rispristino il giocattolo? Ciao e grazie.

        • disinstalla tutto cio che hai installato e sei a posto così torni senza problemi alla versione 11.2

  • marco

    In genere è meglio evitare sudo con i programmi grafici, vedi http://www.psychocats.net/ubuntu/graphicalsudo che spiega come usare gksudo per i programmi gtk e kdesudo per i programmi KDE.

No more articles