Ubuntu, Google Earth e i problemi con ia32-libs

A causa della mancanza della libreria ia32-libs non possiamo installare Google Earth in Ubuntu 64 bit, ecco come risolvere il problema.

Google Earth in Ubuntu Linux
Google Earth è una delle applicazioni proprietarie più utilizzate dagli utenti Linux, con la quale averemo una versione “evoluta” di Google Maps con l’integrazione di immagini satellitari, fotografie aeree e dati topografici gestire dalla piattaforma GIS e molto altro ancora.
Installare Google Earth in Linux è molto semplice basta scaricare il pacchetti deb o rpm dal sito ufficiale dell’applicazione e una volta scaricato basta dare un doppio click e confermare l’installazione. Per gli utenti che installano Google Earth in Ubuntu 64 Bit ( o una derivata) non sarà possibile installare l’applicazione a causa della libreria ia32-libs richiesta dal pacchetto ma rimossa dai repository ufficiali Canonical già da alcune release. Ecco come risolvere il problema della libreria  ia32-libs in Ubuntu 64 bit e derivate.

Per risolvere il problema basta semplicemente scaricare ed installare la versione 32 bit di Google Earth in Ubuntu 64 Bit (o derivate) installando tutte le dipendenze  richieste.

Questo ci consentirà di poter risolvere questo problema e installare correttamente Google Earth in Ubuntu 64 Bit, ecco come fare.

Per Ubuntu 64 Bit:

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core
cd /tmp
wget http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb
sudo dpkg -i google-earth-stable_current_i386.deb
sudo apt-get install -f

Per Ubuntu 32 Bit:

cd /tmp
wget http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb
sudo dpkg -i google-earth-stable_current_i386.deb
sudo apt-get install -f

Al termine avremo Google Earth installato correttamente nella nostra distribuzione.

Ricordo che la guida funziona con Ubuntu che derivate ufficiali (come Kubuntu, Xubuntu, Lubuntu, ecc)  e Linux Mint, elementary OS ecc.

14 Commenti

  1. Si può anche installare la versione 64bit ricostruendo il pacchetto senza la dipendenza a ia32-libs

    “askubuntu.com/questions/366438/how-to-install-google-earth-64bit-in-ubuntu-13-10-ia32-libs-dependency-error”

      • Io ho installato separatamente la ia32 e poi google earth 64bit. Non si avviava. Ho forzato l’avvio con -opengl ed è partito, ma dopo un po’ è andato in crash. Devo ancora provare ad installare la versione 32bit però.

  2. Tutto ok Roberto per quanto riguarda i font, unico appunto: non vedo le foto di Panoramio, si puo’ far qualcosa (versione 64 bit)?
    Cmq. grazie

  3. c’è una qualche soluzione per un messaggio di scheda grafica non supporatata? Si tratta di una intel G33. Google-earth parte e funziona ma non vedo le immagini del satellite.
    E’ strano che non vada con ubuntu 14.04 perchè googleearth con distro linuxmint 16 installata sullo stesso pc funziona perfettamente.
    grazie, ciao

  4. ho scoperto che quello che non funziona è la versione di google earth 7.1! … mentre la 6.0.3 invece funziona perfettamente sulla linuxmint 16, infatti ho provato in live la mint 17 con google earth 7.1 e il problema si presenta come in ubuntu 14.04.
    C’è modo di intallare la 6.0.3 anche su ubuntu 14.04?

  5. Ho seguito la guida ma non si avvia comunque. Nella lista programmi è presente google earth, cliccando sull’icona non si avvia nulla purtroppo. Qualche soluzione?

LASCIA UN COMMENTO

Please enter your comment!
Please enter your name here