10 anni fa nasceva GMail uno dei più utilizzati servizi di posta elettronica al mondo utilizzato anche da moltissimi user e developer Linux.

Google GMAIL
Esattamente il 1 aprile 2004 nasceva GMail servizio di posta elettronica gratuito attualmente utilizzato da milioni di utenti di tutto il mondo. Paul Buchheit, il principale sviluppare di Gmail, in una recente intervista al TIME, ha indicato che gran parte del progetto iniziale fu sviluppato con personal computer di scarto e con molti problemi, dato diversi dirigenti di Google non volevano puntare su un nuovo client di posta elettronica.

Per poter incentivare gli utenti ad usare il nuovo servizio di posta elettronica Google deciso di fornire ad ogni account 1 GB di spazio di archiviazione, storage ben 500 volte più grande di quando offerto da Microsoft con Hotmail. Ma la vera rivoluzione arriva dall’interfaccia grafica e dalle funzionalità introdotte, difatti GMail forniva un’esperienza utente completamente rivoluzionaria con la visualizzazione delle email come conversazioni e non come messaggi singoli.

Da allora GMail ha portato grandi cambiamenti, di recente Google ha deciso di rendere ancora più sicuro il servizio con  la connessione crittografata HTTPS per controllare ed inviare le e-mail.
La maggior parte dei client email per Linux  fornisce un’ottimo supporto per GMail, ad esempio in Unity e Gnome Shell troviamo la possibilità di configurare automaticamente Evolution, Thunderbird ecc attraverso Online Account strumento incluso nelle impostazioni di sistema.

  • ldm85

    Il problema non é la ram ma la CPU

  • d4n1x

    Ma una volta installat gli sfondi da dove si reperiscono?

  • alfred

    a me da questo problema durante l’installazione:

    alfred@alfred-laptop:~/plasma-wallpaper-dreamdesktop/build$ cmake .. -DCMAKE_INSTALL_PREFIX=`kde4-config –prefix`

    — The C compiler identification is unknown

    — The CXX compiler identification is unknown

    CMake Error: your C compiler: “CMAKE_C_COMPILER-NOTFOUND” was not found. Please set CMAKE_C_COMPILER to a valid compiler path or name.

    CMake Error: your CXX compiler: “CMAKE_CXX_COMPILER-NOTFOUND” was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.

    — Unable to find libavformat library files!

    CMake Error at cmake/modules/Findlibavformat.cmake:40 (message):

    Could not find libavformat!

    Call Stack (most recent call first):

    CMakeLists.txt:7 (find_package)

    CMake Warning (dev) in CMakeLists.txt:

    No cmake_minimum_required command is present. A line of code such as

    cmake_minimum_required(VERSION 2.8)

    should be added at the top of the file. The version specified may be lower

    if you wish to support older CMake versions for this project. For more

    information run “cmake –help-policy CMP0000”.

    This warning is for project developers. Use -Wno-dev to suppress it.

    — Configuring incomplete, errors occurred!

    • JJ

      Anche a me… è da un po’ che sempre più spesso le guide di LFFL si concludono con un errore! Forse un po’ più di controlli non sarebbero male!…

      • d4n1x

        forse se non sapete compilare è meglio che lasciate perdere 😉

        • alfred

          visto che sai come si fa potresti anche aiutare e spiegare cosa c’è che non va…

          • c’è scritto nella guida come fare
            ma non mi posti l’errore che ti esce non posso risolverlo
            o pensi che sia un mago?

          • JJ

            L’utente alfred ha incollato l’errore nel suo post sopra… cosa altro manca per risolvere l’errore? Io avevo lo stesso messaggio. Ho installato un po’ di pacchetti (build-essentials, kdelibs5-dev, libavformat-dev, libswscale-dev) ed ho aggiunto il prefisso cmake_minimum_required(VERSION 2.8) al file CMakeLists.txt, ma continuo ad avere errori:

            CMake Error at /usr/share/kde4/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE):

            Could NOT find KDE4Workspace (missing: KDE4Workspace_CONFIG)

            Call Stack (most recent call first):

            /usr/share/kde4/apps/cmake/modules/FindKDE4Workspace.cmake:70 (find_package_handle_standard_args)

            CMakeLists.txt:14 (find_package)

            — Configuring incomplete, errors occurred!

            @d4n1x: se sapevo compilare NON seguivo una guida, lo facevo da me e basta. Se seguo una guida significa che HO BISOGNO DI AIUTO per fare quella cosa…

            Grazie!

          • alfred

            bene, anche io ho dopo aver installato alcuni pacchetti mi ritrovo con questa situazione:

            alfred@alfred-laptop:~/plasma-wallpaper-dreamdesktop/build$ cmake .. -DCMAKE_INSTALL_PREFIX=`kde4-config –prefix`

            — Found components for libavformat

            — libavformat_INCLUDES = /usr/include/libavformat

            — libavformat_LIBRARIES = /usr/lib/x86_64-linux-gnu/libavformat.so

            — Found components for libavcodec

            — libavcodec_INCLUDES = /usr/include/libavcodec

            — libavcodec_LIBRARIES = /usr/lib/x86_64-linux-gnu/libavcodec.so

            — Found components for libswscale

            — libswscale_INCLUDES = /usr/include/libswscale

            — libswscale_LIBRARIES = /usr/lib/x86_64-linux-gnu/libswscale.so

            — Found components for libavutil

            — libavutil_INCLUDES = /usr/include/libavutil

            — libavutil_LIBRARIES = /usr/lib/x86_64-linux-gnu/libavutil.so

            CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (MESSAGE):

            ERROR: cmake/modules/FindKDE4Internal.cmake not found in

            /home/alfred/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps

            Call Stack (most recent call first):

            CMakeLists.txt:12 (find_package)

            — Configuring incomplete, errors occurred!

          • che distribuzione usi
            se kubuntu
            sudo apt-get install build-essential

            e riprova
            se non va dai

            sudo apt-get install libphonon-dev

          • JJ

            Fatto, erano già installati, niente da fare.

          • d4n1x

            Il problema che il processo di compilazione non è una cosa per tutti bisogna avere determinate conoscenze e seguire una guida generica è utile solo se si hanno già altre conoscenze e si è in grado di usare google. Il 90% degli errori che da cmake e ma che sono risolvibili tramite googlerisolvibilirisolvibili con

        • giocitta

          Come sarebbe bello se certi atteggiamenti “da saputello” venissero evitati in un blog che mira ad aiutare soprattutto i meno saputelli…

          • d4n1x

            Stai facendo l’avvocato delle cause perse. Premesso che io von questo sito non centro nulla a me da fastidio la gente che spara a zero se non riesci a far funzionare una cosa prima di dire che la colpa è di altri vedi se invece è tua. Questi atteggiamenti da bullo da prepotente e arrogante fanno solo ridere e se tu li giustifichi sei ancora più ridicola. Io quando non sapevo fare chiedevo umilmente aiuto senza sparare a zero su tutto o su siti o forum 😉 imparate un po di educazione e umiltá e vedrete che le persone vi aiuteranno

    • export PATH=$PATH:/usr/lib/kde4/bin

  • GiorgioLoi

    A me alla fine (dopo l’installazione di varie librerie) l’installazione va a buon fine ma non mi ritrovo comunque l’opzione DreamDesktop nella tendina (ho le tre solite colore/immagine/presentazione).

    Se ripeto ‘sudo make install’ ottengo:

    sudo make install
    [ 0%] Built target dreamdesktop_automoc
    [100%] Built target dreamdesktop
    Install the project…
    — Install configuration: “RelWithDebInfo”
    — Up-to-date: /home/giorgio/Scaricati/plasma-wallpaper-dreamdesktop/build/kde4-config –prefix/lib/kde4/dreamdesktop.so
    — Up-to-date: /home/giorgio/Scaricati/plasma-wallpaper-dreamdesktop/build/kde4-config –prefix/share/kde4/services/dreamdesktop.desktop
    — Up-to-date: /home/giorgio/Scaricati/plasma-wallpaper-dreamdesktop/build/kde4-config –prefix/share/apps/dreamdesktop/thumbs/default.png

    Quindi sembrerebbe tutto “up-to-date”, quindi ok.. ma poi tra le opzioni non c’é.. mi sono perso qualcosa?

  • Mane

    Salve
    approfitto e ringrazio ferramroberto per il lavoro fatto fin ora su questo blog (che seguo quotidianamente) 😉

    A me da questo errore riguardo ffmpeg:

    CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
    Please set them or make sure they are set and tested correctly in the CMake files:
    FFmpeg_INCLUDE_DIRS
    used as include directory in directory /home/mane/plasma-wallpaper-dreamdesktop
    used as include directory in directory /home/mane/plasma-wallpaper-dreamdesktop/thumbs
    FFmpeg_LIBRARIES
    linked by target “dreamdesktop” in directory /home/mane/plasma-wallpaper-dreamdesktop

    — Configuring incomplete, errors occurred!

    Ovviamente ho ffmpeg installato e usato la v0.2 di dreamdesktop.. consigli?

    • la 0.2 dovrebbe aver risolto alcuni problemi di compilazione
      prova a dare
      sudo apt-get install kdelibs
      e riprovare la compilazione

      • Mane

        grazie
        installato anche kde libs 5, ma solito problema..
        ah, uso kde su mint.. c’entrasse qualcosa

  • toto

    ciao roberto vorrei sapere io ho provato a istallarlo ma senza risultati la procedura la rispetto tutta ma alla fine il terminale da errore cmake istall cosa faccio mi daresti una mano a istallarlo se si puo mio imail he tafareddu@hotmail.it grazie sarei contento

  • pico

    Dovrebbe essere uscita oggi la versione 0.3, già presente su AUR.

  • Alex

    Ciao e Complimenti per il Blog.
    Ho provato ad installare DreamDesktop ma mi ha dato errore.
    Premetto che sono da poco nel mondo Linux e quindi sono poco esperto, ma è molto affascinante.
    Sto usando l’ultima versione di Linux Mint 16 Petra KDE e l’errore durante l’installazione è il seguente:

    – The C compiler identification is GNU 4.8.1
    — The CXX compiler identification is unknown
    — Check for working C compiler: /usr/bin/cc
    — Check for working C compiler: /usr/bin/cc — works
    — Detecting C compiler ABI info
    — Detecting C compiler ABI info – done
    CMake Error: your CXX compiler: “CMAKE_CXX_COMPILER-NOTFOUND” was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
    Could not find FFmpeg
    CMake Error at /usr/share/cmake-2.8/Modules/FindKDE4.cmake:98 (message):
    ERROR: cmake/modules/FindKDE4Internal.cmake not found in
    /root/.kde/share/apps;/usr/share/mintkde-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
    Call Stack (most recent call first):
    CMakeLists.txt:10 (find_package)

    CMake Warning (dev) in CMakeLists.txt:
    No cmake_minimum_required command is present. A line of code such as

    cmake_minimum_required(VERSION 2.8)

    should be added at the top of the file. The version specified may be lower
    if you wish to support older CMake versions for this project. For more
    information run “cmake –help-policy CMP0000”.
    This warning is for project developers. Use -Wno-dev to suppress it.

    — Configuring incomplete, errors occurred!

No more articles