Nuovo aggiornamento per Ubuntu AMD Catalyst install un nuovo tool con il quale potremo installare driver AMD in Ubuntu e derivate con un click.

Ubuntu AMD Catalyst install
AMD e Nvidia rilasciano driver proprietari per Linux attraverso un file l’installazione il quale può portare alcuni problemi soprattutto ai nuovi utenti che non conoscono molto  bene eventuali comandi da riga di comando. Per fortuna in Ubuntu e derivate è possibile installare driver proprietari per le schede grafiche con estrema facilità direttamente dalle impostazioni di sistema. Se vogliamo aggiornare o installare facilmente i driver proprietari stabile o beta AMD in Ubuntu Linux possiamo utilizzare un’utile tool denominato Ubuntu AMD Catalyst install.
Ubuntu AMD Catalyst install è un’utile tool il quale ci consente di installare l’ultima versione stabile o beta dei driver proprietari AMD / ATI (anche Legacy) il tutto con un semplice clic del mouse, una volta terminata l’installazione basta riavviare la distribuzione per avere i nostri nuovi driver installati su Ubuntu.

Gli sviluppatori del progetto Ubuntu AMD Catalyst install hanno recentemente rilascio la nuova versione 3.3 che corregge diversi bug riscontrati in Ubuntu 13.10 garantendo anche il supporto per Ubuntu 12.04, 12.10 e 13.04.
Il tool migliora anche la scansione del sistema installando eventuali dipendenze mancanti richieste per l’installazione dei nuovi driver Stabile e Beta cosi da non riscontrare problemi post-installazione.

Ubuntu AMD Catalyst install

Prima d’installare Ubuntu AMD Catalyst Installer dovremo installare alcune dipendenze richieste dall’applicazione per farlo basta digitare da terminale:

Per Ubuntu e derivate 32 Bit

sudo apt-get install libc6 libgcc1 libfontconfig1 libfreetype6 libice6 libsm6 libstdc++6 make linux-libc-dev dh-modaliases libelfg0 execstack gksu dpkg dkms debconf debhelper dh-make fakeroot cdbs build-essential

Per Ubuntu e derivate 64 Bit

sudo apt-get install libc6 libgcc1 libfontconfig1 libfreetype6 libice6 libsm6 libstdc++6 make linux-libc-dev dh-modaliases libelfg0 execstack gksu dpkg dkms debconf debhelper dh-make fakeroot cdbs build-essential lib32gcc1 libc6-i386 

a questo punto installiamo Ubuntu AMD Catalyst install 3.x in Ubuntu e derivate scaricando il pacchetto deb per 32bit o 64bit da questa pagina, una volta installato il pacchetto basta avviare l’applicazione da menu.

  • Luca

    Funziona anche con ATI?

  • Oreste Scalzone

    Qualche settimana fa ho aggiornato il kernel all’allora ultimo 3.12.x per poi vedere che i drivers AMD non li supportavano in quanto compatibili solo con i kernels 3.11.x … Pertanto sono dovuto tornare indietro e mi son detto di non tentare più. Con questo post stai dicendo che posso tentare o mi consigli di restare così come sto? Grazie!

    • Marco Persy

      assolutamente no. controlla il changelog dei driver sul sito ufficiale AMD prima di pasticciare con una cosa così delicata come i driver video. io per esempio mi affido al ppa degli xorg-edgers, di sicuro più affidabili e testati, e non devi diventare folle installando a parte le dipendenze.

      • dentaku65

        L’ultimo driver ufficiale 13.4 e l’ultima versione beta 13.11 di AMD Catalyst non sono compatibili “per sè” con il kernel 3.12.x mainline; per farlo funzionare devi modificare (patch) l’installer di AMD, quello che fa appunto Xorg-edgers per far funzionare le ATI con la versione del kernel citata (tra l’altro xorg-edgers utilizzano la versione 13.8 di AMD Catalyst, quindi nemmeno l’ultima); la modifica comporta l’installazione corretta del modulo DKMS di fglrx che altresì fallisce.

        Personalmente preferisco con le ATI crearmi i miei pacchetti deb dall’installer ufficiale; trovo xorg-edgers troppo invasivo e, spessissimo instabile (a proposito di pasticci qel ppa non è secondo a nessuno). E, specialmente, non mi interessa avere l’utltima versione di Xorg 🙂

        Ad ogni modo la beta 13.11 con l’ultimo kernel 3.11.x di saucy è
        veramente performante.

        • d4n1x

          Ma questo repo xorg-edgers da compatibilità anche per chi usa i driver legacy? Ad esempio io sono incastrato sulla 12.04 per via dei driver legacy 🙁 tempo fa avevo trovato un sitema per la 13.04 ma è stato un disastro in quanto faceva il downgrade di xorg e creava problemi sia con Unity che con KDE :'(

          • dentaku65

            Io eviterei…. xorg-edgers è troppo bleeding-edge; ati legacy quale modello?

        • Daniele

          come si applica la patch? io ho provato a far funzionare i 13.11 su kernel 13.12… niente… sono impazzito… e sono tornato indietro.

  • Iucudi Productions

    Non funziona non usatelo, continua a darmi errori e sopratutto non fornisce un log con i dettagli.

  • Daniele

    hanno sospeso il progetto!!!!!!! ma cacchio… una volta tanto l’esistenza di un soft che facilità la vita dell’utente medio di ubuntu….. -_- (sembra per colpa di AMD)

  • Juljan Sejdi

    radeon 7500/7600series ho pasticciato e non so come venirle fuori, schermata nera al avvio

  • Oleh_

    Se lo uso per la mia datata mobility radeon hd 3650 (rv 635) che per caso mi fa il downgrade a xorg 1.12 in automatico per poi installarmi i driver 13.1?
    Uso Mint 16, kernel 3.12.7

No more articles