Può capitare che che post installazione di Kubuntu o di un’altra distribuzione con ambiente desktop KDE l’avvio sia molto lento, il problema potrebbe essere causato da PulseAudio.

KWin in KDE
Negli ultimi anni gli sviluppatori KDE hanno lavorato molto per rendere sempre più reattivo e veloce l’ambiente desktop riducendo (in alcuni casi anche drasticamente) i consumi di risorse.
La nuova versione 4.11 di KDE risulta molto stabile e soprattutto veloce grazie ad alcune ottimizzazioni che hanno ridotto i consumi di risorse, può capitare però che l’avvio sia molto lento e questo a causa di PulseAudio il server audio presente di default nelle principali distribuzioni Linux compreso Fedora e Kubuntu.
In alcuni casi è un problema di KMix, il cui bug sembra essere risolto anche se molto spesso il vero problema arriva da PulseAudio e alcune difficoltà nel riconoscere la nostra scheda audio all’avvio del sistema, questo rallenta l’avvio di KWin rallentando anche di 15/20 secondi l’avvio dell’ambiente desktop.

Personalmente ho notato questo problema anche in un pc desktop con Arch Linux KDE 64 bit e in un netbook con Kubuntu 13.10 Saucy 32 bit.
Per risolvere questo problema dovremo operare sulla configurazione di PulseAudio esattamente nel file default.pa disattivando il modulo udev dovrebbe al riavvio funzionare correttamente.

Basta digitare da terminale:

sudo nano /etc/pulse/default.pa

e inseriamo il cancelletto davanti alle prime tre stringhe: .

#.ifexists module-udev-detect.so
#load-module module-udev-detect
#.else

lasciamo senza cancelletto

load-module module-detect
.endif

e salviamo il tutto cliccando su Ctrl+x e poi s.

riavviamo e al riavvio dovrebbe avviarsi correttamente.

  • Fabrizio Pelosi

    Mi succede (non proprio sempre però) anche a me con Fedora 19 64bit…
    Quando succede, prima che si carichi l’audio non mi si apre il menu di KDE e non mi si aprono le applicazioni dalle icone e anche chrome non viene caricato prima che si sblocchi…

    Proverò con questo metodo…
    Speriamo 🙂

    • Fabrizio Pelosi

      Però così mi appare una lista lunga di dispositivi…
      Credo che rimetterò come era prima e aspetterò fiducioso in qualche bugfix…
      🙂

      PS: credo che nell’ultimo passaggio vada commentato anche
      .endif

  • boss

    manda in crash anche il sistema alcune volte,cmq dopo aver fatto la modifica nn si sente più l’audio tranne con i vecchi codec flash 11.2 il resto tutto muto anche vlc

  • Gustavo

    non voglio generalizzare, ma penso che , trattandosi di kde sia più indicato suggerire il comando kdesu kwrite, rispetto a sudo nano..
    sudo è installato ma, ad esempio in opensuse, non riesce a darti l’accesso a dolphin o kwrite (kdesu si).. Poi nano io non ce l’ho proprio e penso altre configurazioni con kde..
    Lo dico per chi si avvicina e magari non si ritrova con quelle applicazioni

    • lordronk

      nano è un editor da terminale, è molto probabile che Roberto lo indichi per la sua semplicità

      • nano lo inserisco per il semplice fatto che ogni distro può avere diversi editor di testo
        esempio in kde è possibile avere kate o kwrite
        mi sembra mooooolto strano che non sia in opensuse

        • lordronk

          Se no se vuoi essere proprio sicuro di un editor che c’è sempre in *nix metti vi 😛 ma poi dovresti anche fare una guida su come usarlo xD

        • Gustavo

          se installi opensuse con kde nano non viene installato. Ovviamente c’è nei repository, ma non di default. Io lo dicevo per l’utente alle prime armi, che può non ritrovarsi

  • eticre

    provato.
    non cambia nulla.

  • Luca Sacrato

    E’ un problema noto di kde e basta da terminale dare:
    sudo kate /etc/xdg/autostart/pulseaudio.desktop e inserire alla fine come nuova riga: NotShowIn=KDE; (con il punto e virgola incluso).
    Letto da wiki di Arch: https://wiki.archlinux.org/index.php/KDE_(Italiano)#Desktop_non_risponde_per_alcuni_secondi_all.27avvio

No more articles