ArchBSD è un nuovo progetto, sviluppato dalla comunità Arch Linux, che punta ad offrire le qualità della distribuzione ufficiale (compreso AUR) su kernel di FreeBSD.
Dopo alcuni mesi spesi a portare i principali pacchetti (con applicazioni, ambienti desktop ecc) in ArchBSD da alcune settimane è finalmente disponibile l’installer  della nuova variante di Arch Linux.
Come per il progetto Arch Linux ARM, anche ArchBSD offre un team di sviluppatori impegnati al mantenimento del progetto introducendo correzioni e aggiornamenti vari oltre a creare utili guide nel Wiki dedicato.
ArchBSD ha già diversi utenti impegnati a portare o ricreare PKGBUILD in AUR, in data odierna troviamo già disponibili diverse applicazioni e pacchetti vari.
L’installer di ArchBSD è simile a quello di Arch Linux permette quindi di installare il sistema base, grub ecc attraverso vari script, una volta creato il sistema base potremo terminare l’installazione installando l’ambiente desktop, display manager, applicazioni preferite ecc.

Nei prossimi giorni troverete maggiori dettagli riguardanti il progetto con una recensione dedicata alla nostra installazione con consigli e molto altro ancora.
Per scaricare l’installer di ArchBSD basta collegarci in questo link, ricordo che l’installer è una versione testing quindi potrebbe avere alcuni problemi di stabilità e di supporto con alcune device.

Home ArchBSD

  • angy

    nvidia ha rotto le scatole i ppa non vanno e per le schede optimus ancora niente 

    • i ppa funzionano te lo posso garantirne che versione di scheda grafica hai?

      • angy

        gt 540m ma non va visto che ho due gpu intel e invidia non posso più usare ubuntu dopo 4 anni che rabbia……….. cmq i driver precedenti avevano un po con di problemi.. mi sono confuso con questi

        • questo purtroppo non dipende da me
          hai provato con i driver open?

          • Angy

            e una optimus

  • Io vorrei chiedere un favore, se possibile. Ho un Asus AS36J, con scheda grafica NVIDIA Geforce GT520M. Ogni volta che provavo a installare i driver nvidia (chiudendo X server, eccetera), niente da fare, schermo nero e grafica inesistente. E mi sparivano pure i driver Nouveau. Ora, io son stufo di formattare. Posso avere una guida passo passo per far andare sti maledetti driver? La mia mail è alleteddy@gmail.com. Voglio provarci, senza dover formattare e bestemmiare. Ho Kubuntu 11.04.

    • ma se installi da ppa come da guida non sei apposto
      più semplice di cosi

  • dopo aver installato i driver nvidia non si avvia più l’opengl. Dando il comando 

    glxinfo|grep “OpenGL Version”

    mi dà questo errore

    Error: couldn’t find RGB GLX visual or fbconfig

    • ho provato a togliere il tuo ppa con ppa-purge, solo che ho combinato un casino. in pratica ora nvidia-current nè si disinstalla, non si reinstalla e sta lì, danneggiato. ho provato con sudo apt-get install -f ma niente.

    • penso che quell’errore doveva dartelo anche con i driver precedenti

  • mirkom

    Possiedo un asus aspire 5920G con scheda grafica geforce 8600m GT su ubuntu 11.04
    ho istallato i driver 280.13 da ppa come da guida. 
    tutto ok
    grazie

    • son contento che i ppa funziona a dovere
      grazie x la segnalazione

  • salvo xx

    Ciao ferramroberto, prima di tutto grazzie per il lavoro che metti a disposizione di tutti.
    Io ho installato i nuovi driver nvidia 280.13 seguendo alla lettera la guida qui proposta. Ma mi causa un fastidiosissimo problema, che con questi driver installati ubuntu si blocca alla fine dello splash d’avvio e devo riavviare svariate volte (dalle 5 in su) prima che si avvii, quando si avvia funziona tutto. per ora per ovviare al problema ho retrocesso la versione dei driver alla precedente e tutto va bene. C’è una soluzione o devo attendere la prossima versione dei driver per aggiornare??

    • prova a dare da terminale
      sudo apt-get install –reinstall nvidia-current
      riavvia e poi fammi sapere se va

      • salvo xx

        Ho dato il comando da terminale che mi hai suggerito, ma al riavvio è come se non avessi i driver grafici e quindi senza effetti attivi,  quindi ho forzato la versione dei driver alla 270.41, ma questa volta al riavvio nulla da fare. A questo punto ho disinstallato da terminale i driver, riavviato e installato direttamente i driver 280.13, ma ancora nulla, ho ridato il comando che mi hai suggerito, ma sempre nulla da fare. Ti posto quello che ha restituito il terminale durante l’esecuzione del comendo magari si arriva a una soluzione.

        serture@serture:~$ sudo apt-get install
        –reinstall nvidia-current:

        Lettura elenco dei pacchetti… Fatto

        Generazione albero delle dipendenze

        Lettura informazioni sullo stato…
        Fatto

        0 aggiornati, 0 installati, 1
        reinstallati, 0 da rimuovere e 0 non aggiornati.

        È necessario scaricare 0 B/55,2 MB di
        archivi.

        Dopo quest’operazione, verranno
        occupati 0 B di spazio su disco.

        (Lettura del database… 317994 file e
        directory attualmente installati.)

        Preparativi per sostituire
        nvidia-current v.280.13-0ubuntu1~natty~xup1 (utilizzando
        …/nvidia-current_280.13-0ubuntu1~natty~xup1_amd64.deb)…

        Removing all DKMS Modules

        Done.

        Estrazione del sostituto di
        nvidia-current…

        Elaborazione dei trigger per man-db…

        Configurazione di nvidia-current
        (280.13-0ubuntu1~natty~xup1)…

        update-initramfs: deferring update
        (trigger activated)

        Loading new nvidia-current-280.13 DKMS
        files…

        Building only for 2.6.38-11-generic

        Building for architecture x86_64

        Building initial module for
        2.6.38-11-generic

        Done.

        nvidia-current.ko:

        Running module version sanity check.

        – Original module

        – No original module exists within
        this kernel

        – Installation

        – Installing to
        /lib/modules/2.6.38-11-generic/updates/dkms/

        depmod….

        DKMS: install Completed.

        Elaborazione dei trigger per
        python-gmenu…

        Rebuilding
        /usr/share/applications/desktop.it_IT.utf8.cache…

        Elaborazione dei trigger per
        bamfdaemon…

        Rebuilding
        /usr/share/applications/bamf.index…

        Elaborazione dei trigger per
        initramfs-tools…

        update-initramfs: Generating
        /boot/initrd.img-2.6.38-11-generic

        Elaborazione dei trigger per
        python-support…

        serture@serture:~$

        • che scheda grafica hai?

          • salvo xx

            ho una nvidia  GeForce 8600gs

          • lo supporta non dovrebbe darti questi problemi

          • salvo xx

            Lo so e infatti per fare l’ennesimo tentativo ho rimosso tutto e reinstallato da zero e mentre installava da terminale oltre a tutto quello postato su mi da una riga dove c’è scritto che il file g conf gruppo nvidia setting danneggiato, è possibile rimediare o devo formattare??

          • no quello che mi serve sapere se avevi precedentemente installato i driver proprietari di default

          • salvo xx

            Prima di tutto un grazzie per la gentilissima pazienza e tornando al problema, no con quelli mi è andato tutto bene per un pò poi dopo un aggiornamento del kernel linux mi si avviavano una volta si e cento no, cercando per la rete trovai gli ppa  x-swat  e ho aggiornato con la loro versione. Tutto è andato egragiamente fino all’ultimo aggiornameto dei driver nvidia 280.13. Quindi visto che uso già da tempo i tuoi ppa di gimp e vanno benissimo, ho disinstallato nvidia current e ho disabilitato gli ppa x-swat , quindi ho aggiunto i tuoi ppa e ho installato i driver 280.13 da zero  ma nulla da fare, sono proprio i driver 280.13 che mi danno problemi. Ora  ho installato quelli di default gli nvidia 270.41.06 e sembrano andare, ora il mio dubbio è uno, se per ora lascio questa versione, e attendo la successuva alla 280.13 creo qualche ulteriore problema?? Grazzie ancora ditutto

      • salvo xx

        Scusa ma mi sono incasinato, ti ho postato i messaggi del terminale della prova che ho fatto senza i ppa lffl , questo è quello giusto:

        serture@serture:~$ sudo apt-get install –reinstall nvidia-current
        [sudo] password for serture:
        Lettura elenco dei pacchetti… Fatto
        Generazione albero delle dipendenze      
        Lettura informazioni sullo stato… Fatto
        0 aggiornati, 0 installati, 1 reinstallati, 0 da rimuovere e 0 non aggiornati.
        È necessario scaricare 0 B/55,2 MB di archivi.
        Dopo quest’operazione, verranno occupati 0 B di spazio su disco.
        (Lettura del database… 317996 file e directory attualmente installati.)
        Preparativi per sostituire nvidia-current v.280.13-1~lffl~natty~ppa (utilizzando …/nvidia-current_280.13-1~lffl~natty~ppa_amd64.deb)…
        Removing all DKMS Modules
        Done.
        Estrazione del sostituto di nvidia-current…
        Elaborazione dei trigger per man-db…
        Configurazione di nvidia-current (280.13-1~lffl~natty~ppa)…
        update-initramfs: deferring update (trigger activated)
        Loading new nvidia-current-280.13 DKMS files…
        Building only for 2.6.38-11-generic
        Building for architecture x86_64
        Building initial module for 2.6.38-11-generic
        Done.

        nvidia-current.ko:
        Running module version sanity check.
         – Original module
           – No original module exists within this kernel
         – Installation
           – Installing to /lib/modules/2.6.38-11-generic/updates/dkms/

        depmod….

        DKMS: install Completed.
        Elaborazione dei trigger per python-gmenu…
        Rebuilding /usr/share/applications/desktop.it_IT.utf8.cache…
        Elaborazione dei trigger per bamfdaemon…
        Rebuilding /usr/share/applications/bamf.index…
        Elaborazione dei trigger per initramfs-tools…
        update-initramfs: Generating /boot/initrd.img-2.6.38-11-generic
        Elaborazione dei trigger per python-support…
        serture@serture:~$

  • Alessandro Albanese

    Buongiorno e scusate se l’argomento che posto forse non è di pertinenza qui.
    Utilizzo gnome3 in ufficio con i driver open per schede nVidia. Vi dico questo perchè su tutte le macchine dove ho provato ad installare gnome 3, a parte i vari problemi, i driver proprietari non funzionavano insieme a gnome3 (dopo il login o schermo nero o wallpaper ma non caricava alcun componente di controllo del dm, menu o altro). Leggendo questo post e le risposte ho notato che qualcuno invece pare che utilizzi gnome3 insieme ai driver proprietari. Mi piacerebbe tanto sapere come ha fatto. Inoltre l’installazione di gnome3 non è affatto così semplice, neppure utilizzando i repository indicati qui e altrove.
    Ringrazio per l’attenzione.

    • Gnome 3 / Gnome Shell si può usare tranquillamente con i driver proprietari
      io lo uso per esempio con Arch e Ubuntu, mentre Fedora uso i Driver open

      che scheda grafica hai? perchè in alcuni casi anche se si ha i driver proprietari a volte non funziona proprio per il fatto che non supporta Gnome Shell

      • Alessandro Albanese

        Dunque vediamo, mi dici che esiste una lista di hardware nVidia (schede grafiche) compatibili con Gnome 3/Gnome Shell ? Non ci avevo neppure pensato. Se è così, verifico che schedo ho sui vari pc, posto qui i modelli e vediamo perchè non vanno. Se non sono nella lista sappiamo perchè , ma se ci sono il perchè non lo sappiamo.
        Intanto grazie per la risposta. Inoltre è tempo che penso di aiutare qualcuno nel diffondere ed aiutare, se hai bisogno di una mano dimmelo, lo farò volentieri.

        • Alessandro Albanese

          Ciao, ho la lista dell’hardware interessato.
          >  PC su cui gira gnome3 senza problemi ha una nvidia gt218, ci son installati i driver open, i driver proprietari vanno in conflitto con gnome3
          >  PC con Ati Radeon HD5450 gnome3 con driver proprietari neanche a parlarne, open nada 
          >  Notebook con nVidia GT420M gnome3 non gira ne con i driver proprietari ne con i driver open.
          Ecco la situazione, direi che è un bel garbuglio, anzi direi che di preciso e di sicuro c’è proprio poco.
          Dimenticavo, sul notebook ho installato anche in un altro disco Fedora 15 che ha gnome 3 a bordo nell’installazione, tutto bene, gira senza problemi e con gnome3, non so però se utilizza i driver nVidia o quelli open. 
          A questo punto sembra solo un problema di installazione, di moduli o di chissachè e relativamente ad Ubuntu.
          Fine per ora. 

  • Burana_8

    ciao, grazie per la semplice e funzionale guida. sono nuovo di linux e vorrei sapere se prima di installare i nuovi driver nvidia con il tuo sistema vadano disinstallati i driver nouveau di default. e se si…come. grazie 🙂

    • no installi questi e vanno a sostituire quelli di default

  • niubbox

    grazie mille!! x me (povero niubbo) è manna dal cielo!!

  • Davide

    ciao io ho problemi :(. Ti ringrazio per la guida semplicissima, l’ho seguita alla lettera, ma dopo il riavvio mi esce fuori un errore di incompatibilità, e mi fa avviare ubuntu 10.04 in modalità d’emergenza. ho una gtx 570, mi sapresti aiutare?

  • Davide

    l’errore che mi da è questo

    (EE) NVIDIA: failes to load the NVIDIA kernel module. Please check your
    (EE) NVIDIA: system’s kernel log for additional error messages.
    (EE) failed to load mudule “nvidia” (module-specific error, 0)
    (EE) no drivers available

    Che Faccio??

  • Francesco Sperandio

    ciao
    ho installato i driver e me li segna presenti in impostazione di sistema > driver aggiuntivi…
    ma in impostazioni di sistema > informazioni di sistema continua a scrivermi  grafica sconosciuta

    se dal terminale faccio lspci | greepVGA
    però mi riconosce che è una geforce570

    • dalle impostazioni del driver ti da i driver installati?
      se vai sulle configurazioni di nvidia ti riconosce la scheda grafica se è cosi sei apposto

No more articles