XFCE è un completo ambiente desktop per Linux in grado di offrire stabilità, leggerezza e personalizzazione. Scritto utilizzando le librerie Gtk2 offre un proprio ambiente di sviluppo (librerie, demoni, ecc) e un compositor integrato attraverso il quale possiamo aggiungere trasparenze, ombre ecc al nostro ambiente desktop.
Chi utilizza Xfce su Arch Linux avrà sicuramente notato dei problemi con il tema delle applicazioni QT come ad esempio VLC il quale risulta poco integrato con il tema da noi utilizzato.
Per risolvere il problema basta avviare QTConfig un’utile tool attraverso il quale possiamo personalizzare il tema da utilizzare per le applicazioni e giochi QT.
Basta quindi avviare QTConfig cliccando su ALT+F2 e digitando: qtconfig e in GUI Stile presente nella sezione Apparence scegliamo GTK+ e salviamo.

Avviamo VLC o altra applicazione o gioco QT e dovremo avere il nuovo tema completamente integrato con XFCE, se non fosse cosi dovremo installare il pacchetto libgnomeui il quale offre le librerie corrette per la visualizzazione del tema GTK+ in QT per farlo basta digitare da terminale:

sudo pacman -Sy libgnomeui

al termine riavviamo QTConfig per controllare che sia correttamente impostato il tema GTK+. Avviamo l’applicazione o gioco QT ed ecco il tema correttamente integrato con XFCE.
  • Aniello Luongo

    sudo apt-get install stuntrally
    Lettura elenco dei pacchetti… Fatto
    Generazione albero delle dipendenze       
    Lettura informazioni sullo stato… Fatto
    Alcuni pacchetti non possono essere installati. Questo può voler dire
    che è stata richiesta una situazione impossibile oppure, se si sta
    usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
    non sono ancora stati creati o sono stati rimossi da Incoming.
    Le seguenti informazioni possono aiutare a risolvere la situazione:

    I seguenti pacchetti hanno dipendenze non soddisfatte:
      stuntrally: Dipende: libmygui ma non sta per essere installato
    E: Pacchetto danneggiato

    • che distro hai?

      • Aniello Luongo

        sempre ubuntu 10.04 lts 32 bit

        • prova installando i playdeb come da unity

          fammi sapere
          ciao

          2011/5/26 Disqus

          • Aniello Luongo

            Dai playdeb si installa.

          • si è installato vero?
            son contento
            grazie x la sengalazione

          • Aniello Luongo

            si si è installato e funziona, ho segnalato il bug su

            Issue 72:

            Game not install on ubuntu 10.04 lts 32 bit, lo hanno anche confermato con priorità High.

          • ok fammi sapere se ti risponde nella segnalazione del bug

No more articles