PPA Software Center su Ubuntu

Ubuntu come molti sapranno aggiorna le proprie applicazioni, ambienti desktop ogni 6 mesi rilasciando una nuova release, tutti gli aggiornamenti che riceviamo anche quotidianamente sono di sicurezza oppure di mantenimento della versione installata.
Se vogliamo aggiornare un’applicazione o ambiente desktop oppure vogliamo installare un’applicazione non presente nei repository ufficiali sono presenti i vari PPA di terze parti realizzati da sviluppatori e normali utenti presenti su Launchpad.
Nei mesi scorsi è nato un’valido progetto dedicato alla ricerca di applicazioni da Launchpad e denominato PPA Software Center.

PPA Software Center è un’applicazione con la quale possiamo effettuare ricerche su Launchpad; dai pacchetti a PPA e installarli facilmente nel nostro sistema.

L’applicazione offre un’interfaccia grafica molto semplice, basta semplicemente digitare il nome del pacchetto o ppa da cercare ed effettuare la ricerca.
Al termine della ricerca PPA Software Center visualizzerà tutti i pacchetti correlati elencati per nome del pacchetto, versione, PPA ecc. PPA Software Center si interfaccia con Ubuntu Software Center per verificare la versione della nostra distribuzione e i pacchetti installati, in modo che l’utente non possa installare PPA con pacchetti nelle versioni precedenti alla nostra.

PPA Software Center su Ubuntu

Una volta individuato il pacchetto da installare basta copiare la dicitura d’inserimento PPA, aggiornamento repository e installazione pacchetto. Una volta copiata basta avviare il terminale e ricopiarla al suo interno e confermare.
PPA Software Center è disponibile per Ubuntu 12.04 direttamente da Ubuntu Software Center oppure dallo Store Online Ubuntu Apps.

  • Salvatore Colombo

    eeeeeevvviva.

  • geniale!

  • Ma ricerca nei contenuti del ppa, cioè se io ho il ppa vattelaapesca:ciccio con dentro i pacchetti debian1.deb debian2.deb e debian3.deb quando cerco devo cercare vattelaapesca, ciccio o posso cercare debian1 e mi esce fuori?

    • marcoscarpetta

      Devi cercare il nome del pacchetto (debian1 nel tuo esempio).
      comunque la versione nello store online (di cui non conoscevo l’esistenza) cerca solo pacchetti per precise.
      Su questo ppa: https://launchpad.net/~marcoscarpetta/+archive/ppasc/ sarà tra poco disponibile una versione che riconosce la release di ubuntu automaticamente.

  • Jack O’Malley

    Lo trovo molto utile e semplificativo (se funziona come sembra di capire dall’articolo) però preciserèi anche che è meglio fare delle ricerche sull’affidabilità del manutentore dei pacchetti prima di aggiungere PPA alla cieca.
    Credo che tu capisca cosa voglio dire.

  • Nicola

    Interessante io personalmente non istallavo mai ppa (uso Linux dall’inizio dell’anno), leggendo i post di lffl ho installato almeno 3 ppa differenti senza il minimo problema (Xubuntu 12.04)
    Condivido il pensiero di jacko 3 occorrerebbe la sicurezza che il manutentore sia affidabile

  • Federico Biasiolo

    Come mai non riesco a trovarlo?
    Se lo cerco nel USC non lo trovo e se vado su ubuntu apps quando clicco su “available on the software center” mi si apre USC con scritto pacchetto non trovato…

  • thebcone@gmail.com

    Bello! (confermo che funziona anche su kubuntu indipendentemente dal software center). Per i PPA che conosco funziona per esempio o cercato ffmpeg o mplayer2 e grub (per trovare grub-customizer). Non mi ha trovato amsn, però, almeno per la 12.04, nemmeno io sono ancora riuscito a trovarlo, quindi forse ha ragione a non trovare nulla.
    PS. attenzione a ci fosse interessato ad installare ffmpeg che ho citato sopra e che uso. Il ppa proposto da jon-severinsson/ffmpeg rompe (o rompeva, magari da quando l’ho notato la cosa si è risolta) gsrtreamer 0.10 e le applicazioni che dipendono da gsrtreamer 0.10 (su kubuntu 12.04 la cosa crea pochi problemi perchè di suo non ha dipendenze da gsrtreamer 0.10, ma possono averle i programmi che si sceglie di installare)

  • maniuz

    questo si che mi piace, lo provo subito

  • Xunil70

    io ho un problema in quanto dopo averlo installato tramite il ppa “https://launchpad.net/~marcoscarpetta/+archive/ppasc/” quando provo a farlo partire mi esce sempre questo errore “Esecuzione del processo figlio “/opt/extras.ubuntu.com/ppasc/bin/ppasc” non riuscita (File o directory non esistente)” qualcuno sa come posso risolvere? ps sono su ubuntu 12.04 su gnome classic

    • marcoscarpetta

      Ora funziona, aggiornalo

      • Xunil70

        aggiornato e funziona perfettamente grazie mille!

No more articles