Installare Flash Player 11.3 su Chromium (Linux)

0
18
Flash Player 11.3 su Chromium

L’annuncio da parte di Adobe di abbandonare il supporto per il plugin Flash Player in Linux ha suscitato non poche polemiche a riguardo inoltre le varie alternative come ad esempio Lightspark e Gnash non sono cosi stabili e complete come il plugin proprietario di Adobe.
Per Linux rimarrà comunque possibile installare la versione 11.2 di Adobe Flash Player la quale sarà mantenuta per ben 5 anni passati i quali speriamo che Flash sia solo un brutto ricordo anche grazie all’avanzare di Html5. Google ha cercato di risolvere in parte il problema proponendo per Chrome la versione aggiornata grazie all’API Pepper Plugin integrata nel browser che ci permette quindi di poter utilizzare l’ultima versione del plugin anche in Linux.
Il nuovo Google Chrome 20 offre quindi di default il nuovo plugin 11.3 nella versione per Linux, per questioni di licenza in Chromium non avremo di default tool proprietari come il plugin Flash Player, il PDF reader codec ecc.
Possiamo però integrare il plugin Flash Player 11.3 su Chromium in un secondo momento con molta facilità offrendo quindi la possibilità di poter utilizzalo anche sulla versione open del browser di Google.

Se abbiamo Arch Linux sarà molto semplice installare il plugin Flash Player 11.3 in Chromium basta semplicemente installare il pacchetto chromium-pepper-flash da AUR per integrare il nuovo plugin.

Per installare il plugin Flash Player 11.3 si Chromium su altre Distribuzione basta semplicemente scaricare i 2 file manifest.json e libpepflashplayer.so e copiarli nella cartella PepperFlash.
Se abbiamo installato Chromium 20 o versioni successive basta da terminale digitare quanto segue:

sudo -s
mkdir /usr/lib/PepperFlash
cd /usr/lib/PepperFlash
wget http://dl.dropbox.com/u/964512/misc/chromium11.3/manifest.json
wget http://dl.dropbox.com/u/964512/misc/chromium11.3/libpepflashplayer.so

al termine chiudiamo il terminale e avviamo Chromium e andiamo in chrome://plugins e disattiviamo il codec precedente alla versione 11.3 (se installato).
In data odierna il plugin 11.3 è possibile installarlo oltre a Google Chrome solo in Chromium per gli altri browser invece non è possibile integrarlo almeno fino ad oggi.