AMD Catalyst 12.6

AMD aveva annunciato nelle scorse settimane di voler cambiare lo sviluppo dei Driver per le proprie GPU togliendo il rilascio mensile e optando per rilasci importanti con molte novità e correzioni integrate.
A quanto pare non c’è voluto poi molto ad AMD per rilasciare un’importante aggiornamento per i propri driver Catalyst che portano diverse novità sopratutto per gli utenti Linux.
AMD Catalyst 12.6 aggiunge il supporto per 2 nuove GPU R600/R700, inoltre aggiunge il supporto per il nuovo kernel 3.4 e Xorg-Server 1.12 e varie correzioni. Purtroppo AMD non rilascia le note di rilascio del nuovi driver per Linux quindi non è possibile conoscere quale correzioni siano state introdotte nella nuova versione.

I driver AMD/ATI Catalyst 12.6 sono già disponibili per Windows e Linux: per scaricarli, basta collegarci a questa pagina.
Per installare o aggiornare i nuovi driver AMD Catalyst 12.6 su Ubuntu e derivate basta digitare da terminale:

wget http://www2.ati.com/drivers/linux/amd-driver-installer-12-6-x86.x86_64.run
chmod +x amd-driver-installer-12-6-x86.x86_64.run
sudo sh ./amd-driver-installer-12-6-x86.x86_64.run

Dal wizard confermiamo quindi l’installazione dei nuovi driver, ed al termine digitiamo:

sudo aticonfig –initial -f

E riavviamo.

  • mimmo

    potete gentilmente scrivere tutta la procedura compresi i passaggi preliminari dove bisogna eliminare eventuali altri pacchetti?

    grazie mille

    • non servono passaggi preliminari
      per installare i driver fai come indicato nell’articolo

  • Occhio che questi driver non supportano le vecchie schede (HD 2000/3000/4000). Per queste ultime, bisognerà aspettare altri driver in uscita verso metà luglio.

  • fra

    occhio che prima di installare i nuovi driver vanno tolti i vecchi!
    qua ci sono le istruzione per ubuntu precise:
    http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide

    sono per i 12.4 basta sostituire 12.4 con 12.6

  • mimmo

    e per togliere i driver open?

    • non serve puoi installare i proprietari e all’avvio partiranno quelli

  • LJ

    grazie, cmq attenzione la guida è un pò troppo generica …… meglio spiegali i comandi che buttarli li così.

    • i comandi son giusti

      • Vincenzofranzo

         e sono gli stessi da sempre … posso capire se sei un nuovo utente linux ma in caso contrario ci vorrebbe maggiore applicazione. Consideradno che con un semplice copia/incolla funzionano tutti 😀

  • Mat

    a me i 12.3 davano problemi con compiz e gnome classic (ubuntu 12.04). Con questi potrei risolvere il problema?

    • non saprei dato che non rilasciano nessuna nota di rilascio per i driver per linux
      gnome classic è sconsigliato utilizzarlo con compiz forse è anche li il problema
      usa la versione senza effetti e vedrai che funziona meglio
      compiz tranne che per unity è meglio abbandonarlo altrimenti sono sempre disastri

  • mimmo

    con ubuntu 12.04 kernel 3.4 e radeon hd 7850, ho avuto problemi di installazione

  • Matteo

    Qualcuno con il kernel 3.4 è riuscito ad installare i driver? Io avevo provato a installarli quando erano ancora un Beta e non ce l’avevo fatta… inoltre la patch che trovavo in rete non risolveva il problema…

    • mimmo

      allora io ho avuto problemi con il kernel 3.4, ho una radeon hd7850…ho risolto entrando con il kernel 3.2.0-25 e funzionano

  • mrcreD

    io ho un’ ati 6320, ma mi dice che non è supportata come scheda video…

  • kalel

    perchè non installa il control center?

No more articles