Dalla community di XFCE arriva un nuovo plugin che ci consente di impostare facilmente gli hotcorner.

xfce4-hotcorner-plugin
Lo sviluppo di XFCE sta rendendo il famoso ambiente desktop open source sempre più stabile, sicuro e soprattutto completo. Gli ultimi aggiornamenti hanno introdotto numerose funzionalità e personalizzazioni varie, che possiamo aggiungere anche grazie a plugin di terze parti. Tra questi vi vogliamo segnalare il nuovo plugin con il quale potremo impostare gli Hotcorner, funzione che consente di poter velocizzare alcune operazioni posizioniamo il cursore in un’angolo della scrivania.
xfce4-hotcorner-plugin è un progetto ancora in fase di sviluppo che include già alcune utili funzionalità come ad esempio la possibilità di minimizzare tutte le finestre, avviare xfdashboard (per maggiori informazioni), avviare lo screensaver o spegnere il monitor oppure avviare un comando.

Ecco un video realizzato dal nostro lettore Dea1993 dedicato a xfce4-hotcorner-plugin (che ringraziamo per la segnalazione).

xfce4-hotcorner-plugin è già disponibile per Xubuntu tramite PPA Xubuntu Extras digitando:

sudo add-apt-repository ppa:xubuntu-dev/extras
sudo apt-get update
sudo apt-get install xfce4-hotcorner-plugin

Possiamo installare xfce4-hotcorner-plugin in Arch Linux e derivate attraverso AUR.

Home xfce4-hotcorner-plugin

  • gregoryhouse

    Ho provato questa guida…tutto bene nessun problema ma il tempo d’avvio è lo stesso, non cambia nulla :((

    Dove ho sbagliato?

    • matteo

      Non hai sbagliato tu, è sbagliata questa guida. Il rallentamento che può causare sull’avvio di Mint dipende dall’hardware in uso, su hardware recente o comunque non datato non si nota rallentamento. Parliamoci chiaro, se davvero gli sviluppatori di Mint fossero in grado di rallentare il boot del 20% su un qualsiasi PC con una banale applicazione ad avvio automatico, potrebbero abbandonare linux e passare a windows! 🙂 il titolo della guida serve solo per attirare utenti, è una precauzione inutile su PC che non siano davvero vecchiotti.

      • Guest

        E allora che devo fare? Lo ripristino o no? Non ho capito allora la guida bene.

        Serve davvero bloccare il Mintoupdate? grazie 🙂

        • matteo

          Secondo me non serve affatto, e comunque dubito che rallenti di manciate di secondi l’avvio del PC. Dimmi qualche caratteristica hardware del tuo PC… Se ti trovi bene con gli aggiornamenti automatici io lo terrei

          • gregoryhouse

            Come dicevo anche dall’alto post, ho la Titan con i7 a 16GB di RAM.

            Con o senza spunta rimane tutto uguale, la rimetto

      • gregoryhouse

        Il mio messaggio si è cancellato 🙁

        Posso ripristinarlo in tranquillità allora?

    • Luca Tavecchio

      evidentemente il tuo hardware è sufficientemente potente da rendere praticamente indifferente questa modifica.. sicuro avere l’updater all’avvio automatico su sistemi più datati può dare qualche rallentamento… ma come scrivono sotto.. cmq se fai il processo all’inverso non credo ne avrai alcun danno.

      • gregoryhouse

        Si lo ripristino fa niente

  • Duetto

    caspita, siete utenti linux: PROVATE!!! 🙂
    http://www.bootchart.org/

  • Be io già sulla vecchia versione di mint avevo notato la pesantezza di mintupdate e in generale dei vari tool che girano su ubuntu e derivate… per quello su ubuntu l’unica scelta era la command line (come su arch, gentoo, etc 🙂 )

  • SalvaJu29ro

    Mammamia, mi viene il mal di testa guardando il video xD

    • kernele

      capita facendo video guide con linux.
      si va veloci perché si ha paura di un crash di qualche applicazione.
      a me viene il panico per xorg.

      • SalvaJu29ro

        Più che la velocità è il continuo uso degli hot corner che mi fa uno strano effetto

      • ehmmm a dir la verità i crash non c’entrano niente… non so tu cosa usi, ma io non ho mai dei crash, a parte steam che ultimamente a volte crasha senza motivo, ma di certo non è un problema del mondo linux, anche perchè mi ha sempre funzionato fino a non molto tempo fa…

        e poi se faccio un video e qualcosa mi va in crash se proprio non voglio mostrare il crash, lo rifaccio da capo.. tanto erano 50 secondi in tutto,… ma poi esendo ancora un plugin in sviluppo, avrei lasciato tranquillamente il pezzo in cui crasha il plugin così che la gente vede che ancora non è perfetto

    • xD… l’ho fatto troppo confusionario?? sorry, è che dovevo far vedere giusto come funzionava il plugin, poi non sono esperto a fare video, li faccio così come mostrerei ad una persona il funzionamento di qualcosa.

      • SalvaJu29ro

        Nono, non è colpa tua.
        Più che altro ogni volta che guardo video con linux con gli hot corner mi fa questo effetto
        Non so perchè, ma andare sempre nell’angolo e vedere tutte le applicazioni aperte boh…sono antico xD
        Poi ovviamente hai dovuto velocizzare le cose

        • EnricoD

          io se uso gli hotcorners ad es noto che mi si disattivano i fotorecettori sulla retina dell’occhio sx e praticamente perdo in pronfondità nella percezione .. quindi meglio di no se no mi sfrocio per le scale

          • SalvaJu29ro

            Scherzi? Ahahahah

          • EnricoD

            no, se tu vai a misurare la risposta spettrale dei fotorecettori sulla retina del mio occhio vedi che il segnale in intensità è molto ridotto…
            effetto hotcorner che quencha i pigmenti e che fotte l’effetto parallasse e quindi percepisco alla cavolo la profondità
            purtoproro è csoi
            vedi? provoca anche una forma lieve di dislessia

          • oddio… bisogna iniziare a mettere le controindicazioni anche negli hotcorner allora xD

            o addirittura farsi prescrivere la ricetta dal medico per poter usare certe funzionalità….

            ovviamente sono ironico 🙂

  • kernele

    secondo!
    ottimo!

    a quando un WM degno di nota e la sostituzione di xfdesktop?
    allora, xfce sarà davvero un bel DE.

    • SalvaJu29ro

      Prima dovrebbero velocizzare il passaggio alle gtk3

    • perchè mai dovrebbero sostituire xfwm con altro??
      xfwm per me è ottimo, al limite devono aggiungere il supporto a wayland e a clutter per renderlo più moderno, ma da qui a dire che deve essere sostituito ce ne passa, e poi puoi tranquillamente usare altri WM tipo compton ma poi usandocompton perdi l’anteprima delle finestre nel menu alt-tab che per me è importante

      • heron

        non so se mi diverte o mi fa tristezza la gente che parla senza sapere assolutamente nulla dell’argomento… e che addirittura critica per sembrare più intelligente.

        • kernele

          io invece so cosa porta a prendere per oro colato tutto quello che arriva dal mondo linux.
          1: tanto tempo a disposizione da perdere per smanettare.
          2: non avere alcune necessità dalle propie macchine.

          3: essere relativamente “frechi” ed entusiati del mondo linux.
          nella terza ipotesi, spesso si ha delle fette di salame negli occhi.

          EDIT
          ho 3 macchine in singolo boot con linux.

          • 1) ma sei serio?? uso linux da anni ma non c’è necessariamente bisogno di dover smanettare… linux lo usa anche mia madre, una mia sorella e la mia ragazza che non sono certo esperte del mondo dell’informatica.

            2) sicuro?? io lo uso e tra l’altro uso archlinux, non distribuzioni come ubuntu o debian ecc.. ma da questo PC pretendo che sia affidabile e privo di problemi visto che mi serve per l’università…. ma guarda un po.. non ha mai mostrato alcun problema… inoltre anche mio padre lo usa e ci lavora pure col suo portatile a volte, e c’ha anche scritto software in php per l’azienda.. quindi non mi sembra che la tua seconda affermazione sia vera… anzi mi sa tanto di ca**ata

            3) non so cosa vuol dire “frechi”, ma per il resto della frase, queste persone ci sono ovunque, non in linux e basta… possiamo dargli anche il nome di fanboy, che difendono a spada tratta sempre il loro prodotto amato anche quando non è difendibile e ci sono anche ssu windows, sul mondo apple (e qui sono tanti), su android, su linux, su tutto quindi è inutile stare a dire che su linux ci sono persone col prosciutto negli occhi.. perchè tanto ogni cosa ha i suoi fanboy.

            quindi questi 3 punti che hai fatto, sono utili quanto un rotolo di carta igenica finito, in bagno, e poi hai pure 3 macchine con singolo boot con linux??? e allora mi chiedo…
            1) che diavolo di distribuzioni usi se hai sempre bisogno di “smanettare”

            2) che cavolo gli fai se c’è sempre da smanettare e se non devi avere nessuna necessità dalle macchine con linux preinstallato

          • Bubu

            Ciao scusa se ti disturbo,ma so che usi arch e firefox, volevo chiederti se per caso, anche tu, in questi giorni hai ricevuto l’avviso da parte del browser, che flashplugin è obsoleto e di conseguenza vengono bloccati tutti i video per motivi di sicurezza.

          • TopoRuggente

            Uso Arch e si pure a me flash è segnalato come Outdated.

          • Bubu

            Quindi è consigliabile disabilitarlo fino a un prossimo aggiornamento?

          • MoMy

            In teoria dovresti verificare la versione e in caso aggiornare. ^^

          • In teoria è impossibile in quanto siamo fermi alla 11.2 la soluzione è andare in componenti aggiuntivi -> plugin e selezionare “attiva” per flash plugin, altrimenti usare soluzioni alternative gnash etc che sarebbe anche meglio ma meno funzionali.

          • la versione è la 11.2, ma non è che non ci sono più aggiornamenti… infatti ogni tanto si aggiorna… solo che siamo sempre fermi alla 11.2 e cambia solo l’ultimo numerino della versione, infatti adobe non fa più aggiornamenti di funzionalità per linux, ma solo aggironamenti di sicurezza

          • Si e quindi la 11.2.il-numerino-che-vuoi è sempre inferiore alla 14.x per cui ti verrà sempre segnalata come obsoleta. Tutto qua 🙂

          • non è vero… a me se vai nei componenti aggiuntivi di firefox… e verifichi se i plugin sono aggiornati o no.. se hai l’ultima versione del ramo 11.2 non ti dice che è obsoleta ma aggiornata, infatti in questo momento firefox su archlinux mi sta dicendo che flashplayer è aggiornato infatti ho flash 11.2 aggiornato all’ultima release.

            vedila un po come l’avere un kernel lts oppure un kernel non lts oppure come usare firefox stable o firefox esr… lo sviluppo procede in modo parallelo… puoi avere firefox esr o il kernel lts aggiornati all’ultima release, ma non sono considerati obsoleti perchè comunque sono mantenuti… e lo stesso accade con adobe flash 11.2… se hai l’ultima versione di qeusta release allora sei aggiornato.. poi magari ci sono rari siti in cui se non hai flash abbastanza aggiornato non ti funziona oppure funziona male, però firefox ti dice che è aggiornato flash e quindi non te lo disabilita

          • Bo io ce l’ho aggiornato e me lo segnala su tutti i siti che richiedono flash a prescindere ho anche io arch linux.

          • heron

            se ti da fastidio, apri about:config e imposta a false la stringa seguente:
            extensions.blocklist.enabled

          • Io ho anche risolto in altro modo era per parlarne non per lamentarmi.

          • Bubu

            Io ho trovato la soluzione nel wiki di firefox, nella sezione “firefox detects the wrong version of my plugin”.

          • Brau

            Io invece uso la 18 con pipelight, solo che ho il problema di perdita focus quando guardo un qualsiasi video flash (in pratica, l’area dove posso interagire si restringe solo a quella interna al video, sono costretto a richiamare la schermata di spegnimento e fare “annulla”)… È un problema che capita solo a me? [Xubuntu 14.04, ultimi driver open Radeon]

          • TopoRuggente

            Dipende io l’ho lasciato ad attivazione manuale, nei siti che conosco poi lo attivo di default, negli altri lo attivo manualmente se proprio non ne posso fare a meno.

          • Bubu

            Spulciando nel wiki di arch ho trovato la soluzione….risolto eliminando pluginreg.dat da ~/.mozilla/firefox/some name.default/

          • a me non è uscito nessun avviso.. e ho firefox aggiornato alla versione 39.. flash boo non so che versione sia.. non ricordo quando c’è stato l’ultimo aggiornamento

          • tomberry

            11.2 abbiamo su linux (cambiano subversion, attualmente a me segnala 11.2.202.468, sembra un’indirizzo ip 😛 ), per controllare, basta andare in componenti aggiuntivi, a sinistra selezionare plugin, e vedrete quelli disponibili sul sistema (con varie opzioni)…

          • TopoRuggente

            Ce li giochiamo sulla ruota di Napoli !!!

          • si che siamo fermi a questa schifezza di 11.2 lo ricordavo… ma non ricordavo la versione precisa e non avevo voglia di controllare….
            comunque è vero sembra un IP anche se l’ultimo numero ha sforato un po xD

          • Franco

            Sicuro che non sia un messaggio legato a certi siti malandrini tipo facebook o altri peggiori? Non credo che dipenda da quello che hai installato.

          • Bubu

            Quando entro in siti che richiedeno l’uso di flash, inizia a lampeggiare in alto a sinistra un “cubetto lego” rosso e mi avvisa che il plugin è obsoleto e di aggiornare all’ ultima versione…..peccato che ho installato l’ultima versione……

    • in ogni tuo commento dici sempre… primo.. secondo… terzo…. ma lo vuoi capire che non stiamo facendo una gara e non si vince nulla?? non interessa a nessuno se commenti per primo, per secondo, per ultimo o se non commenti per niente… sembra come i bambini su youtube che si divertono a commentare “primo yeahhh ke figo xxxxx!!!111!!!1!”

      • kernele

        sei ancora troppo giovane per capire che la vita è una “barzelletta”.

        • EnricoD

          life sucks ma quale barzelletta

          • AlwaysLookToTheBrightSideOfLif

            life is laught and death, it is a joke 🙂

          • EnricoD

            a joke de merda

          • EnricoD

            yep, a (shitty) joke

  • su archlinux è disponibile solo su AUR4 non su AUR3 quindi se non usate i repository di aur4 non potete installarlo da aur

  • Ste

    Nel video c’è un tema per le finestre veramente carino, come si chiama?

    • il tema che uso per il decoratore delle finestre è paper
      snwh. org/paper/

      • Ste

        Grazie! 🙂

  • Bubu

    Provato ieri e per me è inutilizzabile, ci mette almeno 3 secondi prima di eseguire l’azione scelta.

    • mmm strano… da me è velocissimo e molto reattivo… che hardware hai?? e quale comando impiegava così tanto?? un comando standard o uno personalizzato?? tieni conto che se esegui ad esempio il comando “xfdashboard” se questo non ha il demone precaricato è un po lento ad eseguire perchè è un po pesantuccio.. lo stesso discorso avviene se tenti di avviare software personalizzati come ad esempio firefox o altro… impiega un po perchè ci vuole proprio del tempo a far partire il software… sennò ti dico da me è istantaneo… uso 2 hotcorner in basso a sinistra avvio xfdashboard (ho il demone in autoavvio) ed è velocissimo, praticamente istantaneo come tocco l’angolo, mentre invece un altro hotcorner è quello in alto a sinistra per far aprire il menu delle applicazioni whisker e quello impiega un po più tempo ma non tanto… impiegherà tipo mezzo secondo oppure una roba tipo 300ms

      • Bubu

        provato su un eeepc e anche il mostra desktop ci mette tanto tempo

        • boo magari l’hardware è troppo poco potente.. il tuo eeepc ha un atom o un celeron ULV??

          • bubu

            atom…..peccato….unica soluzione funzionante per il mio povero eeepc è gala, solo che non mi piace come gestisce il posizionamento delle finestre, alla fine lo riprovo ciclicamente, ma poi torno a xfwm4.

No more articles