I developer Canonical hanno deciso che in Ubuntu 12.04.5 avrà il Kernel 3.13 e driver open e proprietari di Ubuntu 14.04 Trusty LTS.

Ubuntu
Manca circa un mese al rilascio di Ubuntu 12.04.5, versione di aggiornamento della famosa LTS che include principalmente tutti gli aggiornamenti di sicurezza e di mantenimento rilasciati fino a pochi giorni prima, in maniera tale da poter offrire all’utente una distribuzione già aggiornata post installazione.
Per Ubuntu 12.04.5 i developer Canonical hanno deciso di includere lo stesso Kernel e stack grafico di Ubuntu 14.04 Trusty LTS in maniera tale da fornire una maggiore stabilità e sicurezza all’intera distribuzione.

A beneficiarne dell’aggiornamento sono anche le derivate di Ubuntu 12.04 Trusty LTS, tra queste elementary OS 0.2 Luna, distribuzione che con i nuovi aggiornamenti sarà non solo più stabile  ma anche più performante visto le ottimizzazioni incluse sia nel Kernel che nei driver open e proprietari di Ubuntu 14.04 Trusty.

Per chi attualmente utilizza Ubuntu 12.04 Precise LTS o una derivata ufficiale o non, non dovrà reinstallare la distribuzione ma semplicemente aggiornarla per ricevere i nuovi aggiornamenti sia del Kernel e lo stack grafico di Ubuntu 14.04 Trusty.

  • Jacopo Ben Quatrini

    Allora invece di installarmi Lubuntu 14.04 LTS facevo prima a installare la 12.04 (almeno finchè non arriva la nuova debian stable <3 )

  • biosniper

    nel quartultimo rigo c’è scritto “Ubuntu 12.04 Trusty”…, per favore non confondiamo i pangolini con le capre
    🙂

  • ge+

    Il kernel 3.13 è una EOL mantenuta solo da Ubuntu
    Il kernel 3.14 è diventato LTS
    non vedo quindi perchè non adottare il 3.14 (che diventerà via via più stabile) e contribuire al mantenimento..boh

    • ekerazha

      Esatto

    • Ermy_sti

      perchè il tempo di mantenimento del kernel deve corrispondere a quello della distribuzione

      • ge+

        si, ma se fai una distro LTS mettici un kernel LTS, cosi da rendere sensata l’adoziobe dello steso kernelk in due versioni diversi di Ubuntu, tanto lo sai che le release con numero dispari diventano EOL.
        Avrebbero dovuto droppare subito la 3.13, secondo me

  • Francesco Bedussi

    Speriamo di non avere problemi, io dalla 14.04 sono dovuto tornare alla 12.04 per problemi con il proiettore esterno e con l’uscita audio ottica.

    • Ermy_sti

      anche io ho un proiettore ma non capisco cosa centra con l’uscita ottica che è audio

      • Francesco Bedussi

        Nulla, sono 2 problemi diversi

  • Ermy_sti

    Non pensavo che ubuntu fosse così lungimirante! ma con i driver proprietari non ho capito se li aggiornano o meno

  • VincenzOS

    Bisognerebbe anche fare una dovuta precisazione: chi ha Ubuntu 12.04.02 (o 03/04), ovvero con i kernel delle release semestrali, rimarranno senza aggiornamenti di sicurezza le parti upgradate rispetto alla classica 12.04 di base. Bisognerà aggiornare manualmente al nuovo kernel, che sarà supportato per tutto il ciclo di vita della 12.04.

  • muchoman

    Notizia molto interessante…ho due 12.04 che stavo pensando di passare alla 14.04…però non ho capito come aggiornare…basta installare gli aggiornamenti consigliati?

    • VincenzOS

      no, devi fare un avanzamento di versione, cosa che personalmente non ti consiglio. Fai una installazione ex-novo della 14.04. 😉

    • vasco

      Ti prende molto tempo meglio backup e installazione nuova,io ci ho provato per testare e cxon Fastweb ci ha messo un pea e mezzo con 10mega di concessione,e non sempre va a buon fine

    • muchoman

      grazie per i consigli ragazzi ma forse non sono stato chiaro…chiedo venia..ho la 12.04 e stavo valutando la 14.04 ma dopo questa notizia volevo evitare il solito piallamento passando solo alla 12.04.05 ma non capisco se basta fare i soliti aggiornamenti o dare qualche comando particolare da terminale tipo update….il distro upgrade mi ha sempre spaventato, meglio una bella formattata e sto sempre liscio

  • hyo

    notevole…! Con queste basi, chi mai vorrà installare la 14.04? 😉

  • hyo

    solo una domanda, chi utilizza Mint 13 beneficerà dei vantaggi?

    • elisa

      Certamente almeno Spero di si io uso xubuntu;)

  • guerino

    per aggiornare una ubuntu 12.04.4 alla 12.04.5 è sufficiente il comando sudo apt-get dist-upgrade?

    • Andrea

      No quel comando installa la 14.04.
      Devi dare sudo apt-get update ; sudo apt-get upgrade

      Ciao,
      Andrea

      • VincenzOS

        dist-upgrade aggiorna con la nuova versione SOLO se si cambia la lista sources!!! apt-get dist-upgrade al contrario del semplice upgrade crea/rimuove automaticamente le dipendenze per aggiornare tutti i pacchetti, di per se non esegue nessun aggiornamento di versione.

      • .

        con dist-upgrade non aggiorni il kernel quindi dubito che funzioni prima di scrivere provatele le cose

        • .

          *** volevo dire con sudo apt-get upgrade ovviamente

    • .
  • SRC

    Quando uscirà darò sudo apt-get dist-upgrade, ma quante probabilità ci sono che si incasini qualcosa (tipo compatibilità driver video)?

    • VincenzOS

      dist-upgrade NON aggiorna a mò di avanzamento di versione. Kernel/Xorg rimarrano nella release predefinita (es. 3.2.XX), ergo driver e quant’altro non si incasineranno.

  • VincenzOS

    Roberto, ti segnalo di aggiungere questa piccola precisazione: chi ha installato la versione 12.04.00 oppure 12.04.01 rimarrano con kernel/Xorg di default della Ubuntu originaria poichè supportati per l’intero periodo della distribuzione, chi diversamente ha usato le point-release successive, usando le ISO del sito (che hanno predefinito il kernel 3.5/3.8/3.11 per intenderci) uscirà dall’update-manager un avviso per l’upgrade al nuovo stack kernel-xorg della trusty.

  • bucci

    ciao amici sto facendo anch’io l’upgrade che mi ha suggerito il gestore aggiornamenti… prima di procedere ho disinstallato i drivers proprietari della mia ati radeon hd6370m per paura dei soliti problemi…
    Ad ogni modo vorrei reinstallare i drivers proprietari ma con tutte le versioni di fglrx successive alla 13.4 ho un fastidioso problema che è quello della retroilluminazione dello schermo del portatile spenta, ho visto cercando un po’ che ci sono dei workaround per utilizzare questi drivers più recenti, qualcuno mi potrebbe aiutare? grazie a chi volesse intervenire

  • TMZ

    quindi si aggiorna anche xorg in pratica … come funziona per chi usa i driver ati che supportano solo quella versione di xorg? non si aggiorna?

No more articles