Gli utenti Linux crescono anche sulla piattaforma Steam, a settembre 2013 la distribuzione più utilizzata rimane Ubuntu 13.04 Raring 64 Bit con il 0.45% (e il +0.05% confronto il mese precedente)

Valve Steam
L’arrivo di Valve in Linux ha portato grandissimi cambiamenti a tutto l’ecosistema del sistema operativo libero. Grazie alla piattaforma Steam, non solo troviamo nuovi giochi ma anche migliorie hardware riguardanti soprattutto il supporto per le schede grafiche Intel, Amd e Nvidia ed ottimizzazioni varie per OpenGL ecc.
Ogni mese Valve rilascia le statistiche riguardanti la propria piattaforma Steam dal sistema operativo utilizzato dagli utenti all’hardware ecc. Nel mese di settembre 2013 troviamo un lieve aumento degli utenti Linux che hanno installato / utilizzato la piattaforma Steam sulla propria distribuzione. Nel mese di settembre 2013 la distribuzione Linux più utilizzata dagli utenti Steam è Ubuntu 13.04 64 bit con il 0.45% (+0.05% confronto il mese precedente) seguita da Ubuntu 12.04.3 LTS 64 bit 0.18% (+0.18% confronto agosto 2013).

Al terzo posto troviamo Ubuntu 13.04 Raring 32 Bit con il 0.12% (0.00%), mentre al quarto posto troviamo la derivata Linux Mint 15 Olivia 64 bit 0.11% (+0.03%); in quinta posizione Ubuntu 12.04.3 LTS 0.07% (+0.07%).
A settembre 2013 il sistema operativo più utilizzato dagli utenti Steam è Windows 7 64 bit 51.41% (-0.54%) seguito da Windows 8 64 bit 15.00% (+0.99%) e Windows 7 32 bit 12.83% (+0.13%).

Steam a settembre 2013

Il sistema più utilizzato dagli utenti Steam comprende 8 GB di memoria RAM, un processore dual core da 2.3 Ghz a 2.69 Ghz, la scheda grafica più utilizzata è Intel HD Graphics 3000 (che ricordo dispone anche di un’ottimo supporto per Linux) e un’hard disk da 250/500 GB,

Gli utenti Linux aumentano lo conferma sia Valve che Net Applications, l’arrivo di SteamOS potrebbe far avvicinare molti nuovi utenti Linux, staremo a vedere se i dati daranno ragione alle nostre previsioni :D.

  • Questo collegamento risulta inesistente… wget -c http://dl.dropbox.com/u/56720744/kernel_3.3.5_i7/linux-headers-
    3.3.5-030305-i7_3.3.5-030305.201205071254_amd64.deb

  • fernando

    Il mio processore e: Intel® Core™2 Quad CPU Q6600 @ 2.40GHz × 4 .
    Posso installarlo?
    Grazie in anticipo

    • Pcnoproblem

      Si.

  • Tano

    A me da errore in fase di compilazione:
    Selezionato il pacchetto linux-headers-3.3.5-030305-i7.Estrazione di linux-headers-3.3.5-030305-i7 (da linux-headers-3.3.5-030305-i7_3.3.5-030305.201205071254_amd64.deb)…Selezionato il pacchetto linux-headers-3.3.5-030305.Estrazione di linux-headers-3.3.5-030305 (da linux-headers-3.3.5-030305_3.3.5-030305.201205071254_all.deb)…Configurazione di linux-image-3.3.5-030305-i7 (3.3.5-030305.201205071254)…Running depmod.update-initramfs: deferring update (hook will be called later)Examining /etc/kernel/postinst.d.run-parts: executing /etc/kernel/postinst.d/dkms 3.3.5-030305-i7 /boot/vmlinuz-3.3.5-030305-i7Error! Problems with depmod detected. Automatically uninstalling this module.DKMS: Install Failed (depmod problems). Module rolled back to built state.Error! Bad return status for module build on kernel: 3.3.5-030305-i7 (x86_64)Consult /var/lib/dkms/virtualbox/4.1.2/build/make.log for more information.run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.3.5-030305-i7 /boot/vmlinuz-3.3.5-030305-i7
    Provato su portatile Alienware m11Rx3 con ubuntu 11.10 64 bit

    • Tano

      nonostante questo errore che mi ha dato ho riavviato e usa senza problemi il suddetto kernel….ma vorrei capire meglio quell’errore che ho postato, compromette qualcosa o in pratica l’unica cosa a non funzionare è qualcosa relativa a “virtualbox”?

      • Pcnoproblem

        Virtualbox non funzionerà, solo questo …

  • Ciao, quando hai tempo puoi preparare quello per Amd fx ? La versione 64 bit se ti e’ possibile.
    Grazie e complimenti ancora.

    • Ermy_sti

      guarda gli articoli precedenti

  • ava91

    posso usarlo anche per il mio i7 sandy bridge ?? grazie 🙂

  • Massimo Mazzini

    Quando hai tempo per Preparare Quello Per AMD lo fai anche per la Serie Zacate e Ontario E350 E450 …

  • Massimo Mazzini

    I link che hai messo riportano il suffisso I7 ma vanno bene anche con Q9650 ??

    • Pcnoproblem

      Si.

  • eug89

    Ciao, ultimamente ho compilato sia il 3.3.3 che il 3.3.4 usando il tuo stesso metodo (applicando anche la patch di con kolivas) e con entrambi dopo aver dato il comando skipabi=true skipmodule=true fakeroot deban/rules binary-indep ottengo questo errore :
    install: cannot stat `/home/eug89/Builds/linux-3.3.3/tools/hv/*.8′: No such file or directory
    make: *** [install-tools] Error 1 dovuto a questo https://bugs.launchpad.net/ubuntu/+source/linux/+bug/987679 Per adesso ho risolto commentando riga 116 del file /debian/rules.d/3-binary-indep.mk e devo ancora provare col 3.3.5, ma volevo chiederti se hai riscontrato anche tu lo stesso errore?

    • Pcnoproblem

      Certamente, ho risolto creando un file di testo vuoto all’interno della directory incriminata.

  • gabriele

    io ho uno xeon E5506 … secondo voi posso fidarmi a fare l’upgrade. Ho guardato il sito intel ma non riesco a capire le differenze di architettura tra i processori core2 e successivi e il mio, sempre che ce ne siano.

    • Pcnoproblem

      Le ottimizzazioni a carico del kernel per i processori della famiglia Intel sono relative all’utilizzo del set
      di istruzioni appartenente a quella particolare categoria di processori. Ciò consente una maggiore velocità e minori tempi di risposta nell’esecuzione di operazioni che impegnano maggiormente il processore. Il kernel originale deve garantire la più larga compatibilità possibile pertanto non può adottare istruzioni specifiche per una tipologia di cpu escludendo altre: Canonical per esempio dovrebbe sfornare tanti kernel quante sono le varie famiglie di processori.
      Nel tuo caso puoi tranquillamente utilizzare il kernel.

      • gabriele

        errori durante l’installazione, il sistema poi non utilizzava più i driver nvidia, ho dovuto rimuovere 🙁

      • gabriele

        reinstallato senza copia e incolla la procedura va a buon fine, priva di errori, e il sistema sembra effettivamente più reattivo 🙂

  • cioma3

    ciao
    complimenti per le ottime guide!
    p.s. se qualcuno è interessato segnalo la guida per l’installazione su arch e derivate.
    ***.archlinuxitalia.com/2012/01/05/ottimizzazione-di-archlinux/

  • Pio

    tutte le distro con kernel dal 3 in poi scaldano parecchio sul mio laptop con processore i5, tanto che la ventola è sempre in funzione. Con questo kernel dici che il problema si risolverà?

  • Simon Zorzetto

    Ottimo kernel, attenzione però agli ultimi 2 comandi per chi fà copia e incolla ci sono errori di spazio, lo ho installato ieri sera e su un intel core 2 la temperatura media è sui 35 gradi, magari sui prossimi kernel io disabiliterei Kernel debugging.

    • gabriele

      è vero ci sono errori di spazi.
      reinstallato su xeon E5506 e tutto va alla perfezione 🙂
      grazie!

      • Simon Zorzetto

        Figurati 😉

  • Marco Fanuntza

    Installato su Acer 3820T Cpu i350m distro 12.04 tutto ok!!

  • Scusate ma quindi è compilato per i7? da quello che ho letto dovrebbe andare bene anche per i5…avete notato miglioramenti?

  • Ivan

    confermo che non funzionano più i driver nvidia, e la ventola oltre tutto mi sembra che lavori più di prima. Ritorno al 3.3.4. Grazie cmq Aspire 5750G

  • Va bene anche per arch ? Edit: non c’è bisogno, è già incluso nelle sorgenti ^^

    • Pcnoproblem

      No.

  • EliaBaragiola

    il vero problema di linux sono le schede video ibride per portatili, un incubo.

  • Cesare Puliatti

    Funziona tutto egregiamente, solo una cosa non va, il Wifi.

    Ho un Dell M4300 con una Broadcom e infatti il il gestore dei driver(jockey) mi trova il driver. Quando tento di installarlo però fallisce e tramite il log leggo:

    WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl
    WARNING: /sys/module/wl/drivers does not exist, cannot rebind wl driver

    C’è un modo per abilitare questo Modulo in questo kernel?
    Grazie

    • Sortospino

      Ho lo stesso problema sul mio DELL XPS 15…

  • freddie

     il secondo wget non funziona “error 404: not found”

No more articles