Una volta installato Ubuntu è possibile installare applicazioni e giochi preferiti in vari modi. Il più semplice (e sicuro) è di utilizzare Ubuntu Software Center dal quale è possibile effettuare ricerche mirate ed installare, oppure rimuovere, applicazioni con pochi click. E’ possibile inoltre installare applicazioni non presenti sui repository ufficiali di Ubuntu attraverso i PPA, ossia repository di terze parti gestiti da Launchpad, una piattaforma di sviluppo open source realizzata da Canonical. Attraverso i PPA possiamo aggiungere nuove applicazioni, oppure ricevere aggiornamenti di versioni non disponibili nei repository ufficiali, ecc. Infine possiamo installare applicazioni, giochi, kernel ecc, anche attraverso pacchetti .deb che possiamo scaricare dalla rete e da vari blog specializzati (come ad esempio lffl). Può succedere che una volta installata un’applicazione da PPA oppure da pacchetto .deb ci vengano indicati degli errori durante l’installazione impedendoci quindi di effettuare nuove installazioni e peggio ancora aggiornare la nostra distribuzione. 
In questa semplice guida vedremo quindi come risolvere il problema attraverso alcuni semplici comandi da terminale. Ricordo che la guida è valida per qualsiasi versione di Ubuntu e derivate, compresa Linux Mint.

In caso di errori d’installazione la prima cosa da fare è avviare il terminale e digitare:
sudo apt-get --fix-broken install
questo comando dovrebbe risolvere il problema aggiungendo le dipendenze mancanti richieste dal pacchetto installato in precedenza.
Se con il comando precedente non siamo riusciti a risolvere il problema digitiamo sempre da terminale:
sudo rm /var/lib/apt/lists/* -vf   
sudo apt-get update 

In alternativa possiamo anche provare con:

sudo apt-get clean  
sudo apt-get autoclean 
sudo apt-get autoremove

Oppure con

sudo dpkg --configure -a 
sudo apt-get update
Questi comandi dovrebbero risolvere la stragrande maggioranza dei problemi riscontrati durante un’errata installazione di un pacchetto.

via

  • Jupiter funziona anche su Ubuntu (lo usavo con la 10.04) e funziona su LMDE, quidni presumo anche su tutta Debian, derivate e derivate delle derivate.

    • esatto per ubuntu ci sono anche i ppa per mantenerlo sempre aggiornato

      • Mrbenza

        mah.. a me su sulla 11.10 non mi parte, o forse parte e non lo vedo nella sys tray..

        • provalo son gnome classico

          • Guest

            hai ragione, con gnome non ho problemi, con unity non viene visualizzato, ho modificato anche l’opzione di visualizzazione (mettendo all) dal dconf-editor ma ancora nulla.. grazie cmq

          • Mrbenza

            hai ragione, con gnome non ho problemi, con unity non viene visualizzato, ho modificato anche l’opzione di visualizzazione (mettendo all) dal dconf-editor ma ancora nulla.. grazie cmq

  • Axias41

    Io ce l’ho sulla fedora 14, ma non mi salva le impostazioni, all’avvio e al ritorno dallo stand by riparte sempre con la cpu alla massima prestazione. ma per il resto è molto comodo.

    • dovresti riavere le stesse configurazioni all’avvio, hai inserito l’avvio automatico al login?

      • Axias41

        ovviamente.
        ma secondo me è un problema della fedora, anche l’applet di awn fa la stessa cosa, non mantiene la selezione, sempre che possa farlo, cosa che non sono riuscito a capire.

  • Oryu Shen III

    Ho un problema serio nell’installazione, un problema di dipendenze molto, molto, MOLTO fastidioso!!
    “I seguenti pacchetti hanno dipendenze non soddisfatte:
    stuntrally : Dipende: libboost-filesystem1.54.0 ma non è installabile
    Dipende: libboost-system1.54.0 ma non è installabile
    Dipende: libboost-thread1.54.0 ma non è installabile
    Dipende: libboost-wave1.54.0 ma non è installabile
    Dipende: libbulletcollision2.81 ma non è installabile
    Dipende: libbulletdynamics2.81 ma non è installabile
    Dipende: libbulletworldimporter2.81 ma non è installabile
    Dipende: libenet2a (>= 1.3.7+ds) ma non è installabile
    Dipende: liblinearmath2.81 ma non è installabile
    Dipende: libmygui.ogreplatform0debian0 (>= 3.2.0) ma non è installabile
    Dipende: libmyguiengine3 (>= 3.2.0) ma non è installabile
    Dipende: libogre-1.9.0 ma non è installabile
    E: Impossibile correggere i problemi, ci sono pacchetti danneggiati bloccati.”
    Che devo fare??

    • El Ninho

      Hai provato con i comandi della guida? che distro hai?

No more articles