SDDM Simple QML Based Display Manager

SDDM (Simple QML Based Display Manager) è un nuovo progetto open source sviluppato per offrire un display manager  basato su QML in grado di offrire leggerezza e un’ottima personalizzazione.
Indicato da alcuni utenti e sviluppatori il futuro successore del buon vecchio KDM il nuovo SDDM è un progetto nuovissimo ma ha già portato diverse novità compreso il supporto per il nuovo KDE 4.10.
Estremamente personalizzabile  SDDM permette di essere configurato da un file di configurazione sddm-alternative.conf dal quale possiamo cambiare sfondo posizione degli account, gestione di nuovi temi e molto altro ancora.
SDDM Simple QML Based Display Manager richiede pochissime dipendenze (PAM, Xlib e Qt) e sopratutto non richiede nessuna libreria di KDE offrendo quindi la possibilità di essere installato in qualsiasi ambiente desktop compreso LXDE, Xfce, Razor-Qt, Mate, Gnome ecc.

Gli sviluppatori di SDDM hanno rilasciato il primo video che ci descrive l’inrtefaccia grafica e funzionalità del nuovo progetto:

SDDM è un progetto ancora in fase di sviluppo che può avere problemi di stabilità quindi è consigliabile l’utilizzo sono per distribuzioni virtualizzate oppure dedicate al testing.
SDDM è già disponibile per Arch Linux installandolo con AUR, per Ubuntu arriverà a breve un PPA dedicato.

Home SDDM

  • Magog

    funge!!! thanx

  • Marco

    ma questo plugin funziona anche con rai replay?

  • Rossotuttifrutti

    volevo informarti che con firefox4 funziona alla perfezione anche con totem!!grazie ragazzi!!

  • UbuntuX

    Provato con vlc, funziona. Grazie a te per la segnalazione, ed all’autore (ho avuto di comunicare con lui) per rendere fruibili e liberi, contenuti  che alla rai tentano in ogni modo di oscurare a chi non dispone della piattaforma del loro “fornitore ufficiale” leggi m$.

    Ciao.

  • Maria Teresa Boessneck

    Grande !!!! Funziona benissimo senza problemi con Unity 2D. Grazie!!

  • Manfredim

    In tutto il branco la pecora nera non poteva non mancare. Quella sono io. Dopo avere installato Mplayer da linea di comando, ho scaricato l’estensione come da pagina indicata, anche se mi avvisava che non era testata, riavviato FF 5.0, sono andato alla pagina Rai.Tv, ho cliccato su Rai 1 e mi è apparso un avviso di scaricare Microsoft Silverling. Quale errore ho commesso? Dimenticavo, nel menu a tendina di FF – Strumenti- vedo in fondo questa scritta in rosso [Raismth] chech for update. Vi clicco sopra e mi dice No updates available.

    • non devi avviare alcun canale
      devi cliccare sulla freccetta blu nelle nuova barra sopra dove ci sono tutti i canali e basta dopo alcuni secondi di avvia una finestra con il canale scelto

  • Antonio G. Perrotti

    niente… mi dice di installare silverlight. per un attimo appare una finestra “mplayer” poi scompare. i codec credo proprio di averli installati tutti, sicuramente anche molti che neanche mi servono. sta a vedere che dovrò rassegnarmi a sprecare una partizione per un windows qualsiasi. ho un xp acquistato qualche anno fa, ma non ha i driver per gli hard disk SATA, che si possono installare solo da floppy… floppy, l’ultima volta che ne ho maneggiato uno il presidente della repubblica era cossiga….

    • può succedere su rai 1 2 3 per gli altri non devrebbe darti quell’errore
      in alternativa puoi sempre installare moonlight che ti permette la visualizzazione come se avessi silverlight.

      • Antonio G. Perrotti

        già provato. mi dice “you are running an old version of silverlight, etc. dev’essere qualche spiritello maligno…

        • ma hai cliccati sulle freccette blu un alto?

          • Antonio G. Perrotti

            sì. c’amm a fà… ? 🙁

          • è semplicissimo in alto trovi una barra con rai1 rai 2 rai 3 con delle freccette blu affianco ci clicchi sopra e aspetti 10 secondi e si avvia una nuova finestra con il canale selezionato, nella barra inoltre trovi anche euronews
            se non riesci a farlo andare rimuovi l’estensione e installi moonlight
             http://www.lffl.org/2010/10/installiamo-moonlight-silverlight-su.html

            fammi sapere

          • Antonio G. Perrotti

            ho provato ad installare moonlight ma mi dice che è incompatibile con ffx 5. che malumore…

          • Antonio G. Perrotti

            aggiornamento: su elementary funziona, su lucid e mint, sia 10 che 11 non funzionava. anche rai 1, 2 e 3.

          • hai installato i plugin?

  • Millalino

     con FF4 mi andavano i canali da rai 4 in poi …… ma con FF5 nessuno.  mah

    • Type your reply…

    • controlla se hai Adblock e prova a dare il consenso per la pagina

      • Millalino

        ho provato a disabilitare adblock ma nisba…. parte solo rai storia. Magari ho poca banda con la chiavetta, provo questa sera a casa con il wifi. Cmq è strano perche altri canali in streaming riesco a vederli con la chiavetta ma questi no, peccato visto che gli pago anche il canone.

        • se hai poca banda ho nato che si chiude molto spesso la finestra
          se invece hai una connessione veloce vai tranquillo che funziona perfettamente
          ciao

          • Millalino

            grazie roberto, prezioso come sempre. Non ho  capito però perchè con moonlight non va sempre, ogni tanto si apre e chiede di installare nuovamente moonlight … mah

          • hai tolto l’estensione Rai Smooth Streaming Player?

          • Millalino

            si ho provato a togliere l’estensione Rai smooth e provato con moonlight e viceversa, ma non funzionano bene entrambi. Forse ho l’hardware troppo datato per questi plug in, però pensavo potesse bastare un centrino 1.8 ghz ed 1 gb di ram. Magari è la sk video che limita il tutto dato che funzia solo con i driver open (ati 9600 m10 rv 350) ed è per questo che volevo provare con arch, visto che il notebook ha cmq 6 anni.

          • non penso che sia un problema di hardware secondo me dipende dalla connessione
            prova con i dns google per farlo avvia il terminale
            sudo gedit /etc/resolv.conf

            rimuovi (se c’è scritto qualcosa) e inserisci

            # Generated by NetworkManager
            nameserver 8.8.8.8
            nameserver 8.8.4.4

            salviamo e chiudiamo l’editor di testo e sempre da terminale digita

            sudo chattr +i /etc/resolv.conf

            riavvia e prova a connetterti e oltre a navigare più veloce dovrebbe vedersi senza problemi

            per ripristinare come da default basta da terminale digitare:

            sudo chattr -i /etc/resolv.conf

            fammi sapere

          • Millalino

            Ho cambiato i dns ma, non è cambiato niente e nemmeno la  velocita di navigazione è migliorata. Cmq il suggerimento mi sembra buono , cosi quando la famiglia mi lascierà un po piu libero proverò ad installare Arch e nel caso riproverò anche questa soluzione.
            Grazie roberto

          • dovrebbe migliorare almeno un po
            spero che provi ad installare arch e vedrai che è una delle distribuzioni migliori per linux
            ciao

  • Mitm

    salve ragazzi,

    come suggerito da roberto, in caso di difficoltà nell’utilizzo dell’addon è necessario abilitare l’opzione “debug” dalle preferenze componenti aggiuntivi di firefox, e lanciare ff con l’opzione -debug da riga di comando (assicuratevi che non ci siano altre finestre del browser aperte e
    lanciate il comando in console con l’utente predefinito –
    auspicabilmente non root)
    firefox -debug
    così facendo in console vengono mostrati alcuni logs relativi all’estensione e al visualizzatore senza i quali è impossibile capire la causa di eventuali anomalie di funzionamento!

    l’addon può entrare in conflitto con altre estensioni installate.

    [AdBlock] : può bloccare alcuni js tra cui barra_sipra.js che viene utilizzata dall’addon per inserire il menù di selezione canali

    [VideoDownloaderHelper] : alcuni utenti hanno segnalato anomalie quando le due estensioni sono contemporaneamente abilitate.

    per essere certi che i problemi riscontrati non scaturiscano da conflitti con altre estensioni installate, suggerisco di testare l’addon in un profilo di firefox “dedicato”.

    per richieste di supporto specifico fare riferimento alla ns ML

    resto a disposizione per chiarimenti e grazie a tutti per i feedback

    mitm

  • Kar_ban

    Wot mi segnala il sito da cui scaricare l’estensione come pericoloso,suggerimenti …??

    • avanza lo stesso non è pericoloso sarà stata la rai a rompere i cog…

  • Antonio G. Perrotti

    non si riesce più a scaricare l’estensione. sarà un problema temporaneo del server?

  • p91paul

    segnalo che sia con firefox 6 sia con iceweasel 5 ho riscontrato un disastroso abbassamento delle prestazioni in apertura. ovvero firefox impiega dei minuti anzichè dei secondi ad avviarsi. consiglio di lasciare l’addon disattivato e attivarlo solo quando serve appositamente.

    • p91paul

      trovato il motivo. succede quando il server di download del plugin, acab.serverbeer.com è giù per qualche motivo (come adesso). il plugin all’avvio cerca degli aggiornamenti, e se il server è scollegato aspetta il timeout e nel frattempo blocca l’avvio.
      gli sviluppatori promettono di rendere asincrona tale funzione(ovvero il browser parte subito in parallelo alla ricerca di aggiornamenti), e inoltre devono correggere alcuni problemi più che altro formali per far ammettere il plugin su addons.mozilla.org, dove infatti ad oggi non si trova.

  • Roberto

    Da qualche tempo ho installato raismth su Ubuntu 11.04. All’inizio andava bene, ma ora la finestra della RAI mi rimane aperta per 1-2 minuti e poi si chiude. FF è la versione 3.6.22. Forse all’inizio c’era qualche versione più vecchia.
    Grazie intano per questo bel plugin, ma soprattutto grazie anticipate per la risposta che mi darai.

    • Roberto

       Dimenticavo: il problema è su RAI 1, 2 e 3. Gli altri canali funzionano bene. Ho anche provato vlc e totem ed anche loro funzionano bene con tutti tranne RAI 1, 2, e 3, dove non si aprono neanche.

    • Ciao Roberto
      allora il problema non è dello script ma della rai come vedi i problemi sono solo sui primi 3 canali.
      lo script fa già tanto ma come vedi da non pochi problemi
      se usi spesso guardare la rai il mio consiglio è di passare moonlight con quello non avrai più problemi http://www.lffl.org/2010/10/installiamo-moonlight-silverlight-su.html

      • Roberto

        Ti ringrazio per la risposta tempestiva.
        Peccato non poter usare raismth!
        Non so se usare Moolight o non veder più la RAI 😉

        • conforme il tuo utilizzo se guardi la rai spesso ti conviene installare moonlight se invece lo guardi ogni tanto tieniti lo script

          • Roberto

            RAI ed io non andiamo proprio d’accordo! Ho installato moonlight con i relatici codecs e di nuovo non riesco a vedere RAI 1, 2 e 3. Mi si apre la connessione, dopo 3/4 secondo l’immagine si ferma, al centro della schermata appare la scritta buffering e lì rimane finché non cambio canale. Con gli altri canali RAI non succede. Che te ne pare?

    • Kowalsky

      La RAI usa protocolli differenti nelle trasmissioni. Rai 1/2/3 usano lo Smooth Streaming (Il protocollo che ci ha fatto impazzire x decodificarlo) tutti gli altri usano il vecchio protocollo MMS. Lo Smooth Streaming si puo’ riprodurre con RaiSmth solo usando Mplayer oppure il suo recente fork Mplayer2.
      Altri player sono in grado di riprodurre solo lo streaming MMS.
      Da come descrivi il problema sembra una carenza di linea visto che Mplayer si chiude quando raggiunge l’eof se non riesce a scaricare i chunk a/v dal server.
      Una nuova versione con il controllo del ‘buffering’ e’ in test ma non posso darti date certe x il suo rilascio.
      Che versione stai usando? C’e’ una leggera differenza nel meccanismo di cache tra la V2.0.0 e la 1.0.4

      K.

      • Roberto

         Adesso ho installato Moonlight e disinstallato raismth (serviva farlo o potevo lasciarlo?). Comunque li avevo usati tutti e due, con lo stesso risultato. Visto però che succede anche con Moonlight, credo che il problema sia proprio nella carenza di linea.
        Aspetterò la nuova versione e poi vi saprò dire.
        Grazie per quello che state facendo!

      • Roberto

        Grazie a Kowalsky e a Roberto, per l’attenzione!
        Da ieri, automagicamente raismth funziona senza blocchi. Non ho la minima idea di cosa sia successo, ma il problema è sparito.

  • Perchè non su Chromium che è nettamente migliore di firefox??

No more articles