nVidia 295.33 su Ubuntu

nVidia ha recentemente rilasciato i nuovi Driver 295.33, i quali portano con se moltissime novità: in primis il nuovo supporto per il Kernel Linux 3.3.
Tra le altre novità presenti sui nuovi driver nVidia 295.33 troviamo una migliorata compatibilità con i kernel Linux più recenti (compreso 3.2.x), aggiunto il supporto dei display 3D Vision-Ready (che hanno un emettitore a infrarossi NVIDIA 3D Vision integrato nel pannello) e il supporto per 3 nuove GPU: GeForce GTX 680, GeForce GT 630M e GeForce GT 620.

Grazie ai PPA X Swat possiamo installare il nuovo driver nVidia 295.33 su Ubuntu 11.10 e derivate con molta facilità, basta digitare da terminale:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

Al termine riavviamo la distribuzione e avremo il nuovo driver nVidia 295.33 installato.
Al riavvio per verificare la corretta installazione possiamo avviare il pannello di controllo di nVidia oppure digitando da terminale:

glxinfo | grep OpenGL

il risultato dovrà essere:

~$ glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 9600 GSO/PCIe/SSE2
OpenGL version string: 3.3.0 NVIDIA 295.33
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler

nVidia 295.33 è già disponibile anche nei repository ufficiali di Arch Linux per installarlo basta digitare:

sudo pacman -Sy nvidia nvidia-utils

oppure se già installato:

sudo pacman -Syu

  • Ferdiocaid

    per ubuntu 12.04 niente ancora?
     

    • no bisogna aspettare che venga rilasciata la stabile

  • Kronos – ItaliaUnix.com Admin

    C’è un changelog?

  •  Ho Ubuntu 12.04, provo a installare l’aggiornamento dei driver Nvidia, ma non ci riesco, mi dice    “nvidia-current è già alla versione più recente”, ma ho la versione 295.20  .. Soluzioni? thanks

    • è appena arrivato non so se sarà disponibili per il rilascio ufficiale
      visto i continui aggiornamenti ti conviene aspettare il rilascio della versione stabile e vedi se c’è altrimenti vedrai che la troverai su qualche ppa

  • Magno88

    credo ci sia un errore nel primo comando perché poi quando do update mi da un errore

    E: Tipo “ain” non riconosciuto alla riga 3 nel file /etc/apt/sources.list.d/ubuntu-x-swat-x-updates-oneiric.listE: Impossibile leggere l’elenco dei sorgenti.

    come posso rimuovere questo ppa?o come si può far funzionare?

    • hai Oneiric?
      sai
      sudo rm /etc/apt/sources.list.d/ubuntu-x-swat-x-updates-oneiric.list

      • Magno88

        Si Oneiric
        Perfetto tutto tornato alla normalità..peccato però

        • Magno88

          Scusa se rompo ancora ma io sono riuscito a far aggiornare i ppa e anche dopo il comando install ha scaricato e aggiornato i driver ma se do il comando open mi dice:

          OpenGL vendor string: NVIDIA CorporationOpenGL renderer string: GeForce 8400M GT/PCI/SSE2OpenGL version string: 3.3.0 NVIDIA 280.13OpenGL shading language version string: 3.30 NVIDIA via Cg compilerOpenGL extensions:

          ho Oneiric

  • Piecheru

    Ma questi sono i driver ufficiali o quelli open ??

No more articles