Arch Linux di default non aggiunge nessuna applicazione per la gestione degli aggiornamenti, possiamo decidere noi quando aggiornare ma se vogliamo mantenere stabile e sicura la nostra Distribuzione è consigliabile effettuare un’aggiornamento almeno una volta alla settimana.
In questi giorni se proviamo ad aggiornare Arch Linux molto probabilmente comparirà un messaggio d’errore il quale ci indica che il nuovo filesystem-2011.12 provocherà un conflitto con /etc/mtab impedendoci quindi di effettuare l’aggiornamento non solo del pacchetto ma anche dell’intera Distribuzione.
Risolvere il problema è molto semplice basta forzare l’installazione di filesystem aggiungendo –force o -f al comando d’installazione.

Basta quindi da terminale digitare:

pacman -S filesystem –force

e poi completare l’aggiornamento con

pacman -Syu

Ricordo che proprio Arch Linux scoraggia fortemente l’uso di –force o di -f poiché non è sicuro. Tuttavia, in questo caso particolare, è necessario poiché eliminare manualmente /etc/mtab creerebbe problemi a pacman.
Per maggiori informazioni sul problama consiglio di consultare questa pagina.
No more articles