Uno dei maggiori punti di forza di Arch Linux è sicuramente il gestore dei pacchetti Pacman il quale ci permette di gestire i nostri pacchetti con molta facilità e velocità.
Grazie a Pacman possiamo non solo installare, rimuovere o cercare nuovi pacchetti ma anche mantenerli aggiornati semplicemente sincronizzando le liste di pacchetti con il server principale, con un semplice comando ad esempio possiamo sia sincronizzare i nostri pacchetti che aggiornarli.
Alcuni utenti e anche noi abbiamo notato una segnalazione d’errore durante l’aggiornamento impedendoci in completarlo, difatti al comando pacman -Syu durante il processo ci appare il seguente messaggio:

errore: impossibile eseguire l’operazione richiesta (file in conflitto)
initscripts: /etc/profile.d/locale.sh è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

il problema è dovuto che pacman durante l’aggiornamento ha rilevato un conflitto di file e di progettazione.
Risolvere il problema è semplicissimo basta da terminale digitare:

pacman -Syuf

aggiungengo f forziamo l’installazione dell’aggiornamento in modo che venga aggirnato anche initscripts. Al prossimo aggiornamento non avremo più alcun problema.
No more articles