Mozilla in questi mesi ha cambiato radicalmente il proprio sviluppo realizzando vari canali (Stabile, Beta, Aurora e Nightly)  i quali permettono un miglior sviluppo sia di Firefox che per Thunderbird.

Se per Mozilla tutto questo porta notevoli miglioramenti nello sviluppo porta però molte rilasci in poco tempo (in pochi mesi abbiamo già visto ben 3 rilasci stabili) e questo putroppo porta un bel problema per chi sviluppa le estensioni.

Difatti molti utenti si lamentano che con questi recenti rilasci molto spesso le estensioni risultano compatibili anche se come potremo vedere funzioneranno perfettamente con la nuove release.

Come possiamo risolvere il problema in una maniera definitiva?

Per risolvere questo problema basta solo un’estensione denominata  Add-on Compatibility Reporter per far ritornare tutte le nostre estensioni perfettamente compatibili.

Add-on Compatibility Reporter è un semplice add-on per Firefox e Thunderbird il quale ci permette di poter utilizzare qualsiasi estensione anche se non supportata dalla versione del nostro Browser o client Email.
Inoltre al prossimo aggiornamento non avremo alcun problema di incompatibilità

Per installare Add-on Compatibility Reporter su Firefox, Thunderbird basta andare in questa pagina scaricarlo e installarlo nel nostro Browser o Client Email.

  • io ho installato stamattina Firefox6 su ubuntu 11.04 ed ho dovuto fare una ricerca x esclusione di quel addon che subito dopo l’avvio di firefox ed aperta la prima tab, alla seconda tab questo mi andava in crash.

    Si trattada dell’addon x caricare progressivamente le tab: Load tab Progressively (mi pare si chiamasse così).

  • Riccardo Maganza

    Scusa, ma non è proprio così.
    Firefox fa un controllo per vedere che l’add-on sia effettivamente compatibile con la versione del browser.
    Alcuni add-on risultano incompatibili anche se in realtà non danno alcun problema ma altri sono VERAMENTE incompatibili per vari motivi (nuove funzioni, codice leggermente cambiato ecc.)
    Add-on Compatibility Reporter disattiva semplicemente il controllo della compatibilità delle estensioni (infatti nella descrizione mi pare sia consigliata ai beta tester) se funziona, tutto OK, ma se non funziona non puoi farci proprio niente. Puoi solo inviare una segnalazione riportando (Report) il problema…

    L’ADDON NON CORREGGE IN TUTTO E PER TUTTO IL PROBLEMA DELLA COMPATIBILITÀ

    • ma almeno fa girare le estensioni
      il 90% se non più che girano su f5 sicuramente girano anche per f6 e f7
      i problemi arriveranno con f8 ma spero che mozilla comincia a lavorarci su a risolvere questo problema altrimenti gli utenti che perde ad ogni release saranno sempre più

  • Deliquio

    l’ho provato ma ora non mi va più firefox…c’è un modo per toglierlo da terminale?

    • Deliquio

      mi scrive prima:

      ReferenceError: gBrowser is not definedReferenceError: gBrowser is not defined e poi apre un altra finestra con:
      Errore interpretazione XML: entità non definitaIndirizzo: chrome://browser/content/browser.xulLinea numero 234, colonna 5:    <key id="key_scratchpad" keycode="&scratchpad.keycode;" modifiers="shift"—-^

      • Deliquio

        risolto da solo: ho avviato con il comando 

        firefox -safe-mode
        ed ho disabilitato i plugin 😀

        • mi sembra strano che questo plugin abbia dato problemi

        • fabio

          grazie..stesso problema. su ubuntu thx

  • Non mi piace molto, non funziona con Personas per Thunderbird…

  • Questo accade quando non si ragiona con la propria testa! Per correre dietro a Chrome con lo scopo di non perdere utenti, finisce che ne perde di più.

    • è proprio questo che volevo dire
      io uso chrome ormai da un’anno e mezzo e non ho mai avuto problemi con le estensioni
      forse al posto di lavorare su altro dovrebbero comunicare a risolvere questo problema

No more articles