Ubuntu

Da pochi giorni AMD ha rilasciato la nuova versione driver ATI Catalyst, giunti alla release 11.6.
I nuovi Driver Ati Catalyst 11.6 oltre a correggere numerosi bug  ne aumentano le performance.

Ati Catalyst 11.6 aggiunge dei miglioramenti già presentati nell’hotfix ai driver 11.5, in più introducono alcune nuove funzioni grafiche dedicate alle ultime GPU Radeon e miglioramenti prestazionali vari. Nuova la funzione Steady Video che sfrutta la tecnologia APP di AMD permettendo di applicare algoritmi avanzati ai video. Per conoscere in dettaglio le novità dei nuovi Ati Catalyst 11.6 basta consultare questa pagina.

Per installare i nuovi Driver Ati Catalyst 11.6 su Ubuntu 11.04 – 10.10 – 10.04 basta semplicemente avviare il terminale e digitare:

cd && mkdir ati
cd ati
wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-6-x86.x86_64.run
chmod +x ./ati-driver-installer-11-6-x86.x86_64.run

A questo punto

Per Ubuntu 11.04 Natty digitiamo

sudo sh ati-driver-installer-11-6-x86.x86_64.run –buildpkg Ubuntu/natty
sudo dpkg -i *.deb

Per Ubuntu 10.10 Maverick digitiamo

sudo sh ati-driver-installer-11-6-x86.x86_64.run –buildpkg Ubuntu/maverick
sudo dpkg -i *.deb

Per Ubuntu 10.04 Lucid digitiamo

sudo sh ati-driver-installer-11-6-x86.x86_64.run –buildpkg Ubuntu/lucid
sudo dpkg -i *.deb

al termine dell’installazione digitiamo

cd ..
sudo rm -r ati

al termine riavviamo la Distribuzione

in caso di problemi con esitate a segnalarceli commentando questo articolo

  • Nel mio caso ho dovuto dare il comando “sudo sh ati-driver-installer-11-6-x86.x86_64.run –buildpkg Ubuntu/natty” perché quello sopra citato non funzionava

  • Urbani M

    ho eseguito alla lettera le vostre indicazioni da terminale ma rimane presente la versione 11.5 catalist.

    • ti ha creato i pacchetti?

      • In alternativa, si può anche evitare di creare i .deb semplicemente utilizzando “sudo sh ati-driver-installer-11-6-x86.x86_64.run” senza l’opzione –buildpkg

  • Marco

    Come posso fare per aggiornare la mia Mint Debian?
    Grazie Ciao

  • CBMAN

    Eseguo le vostre istruzioni, sembra installare il tutto… ma al riavvio ho sempre le 11.5 installate. perchè?

    • sicuro di aver eseguito tutte le istruzioni? controlla bene

  • Motolo79

    Da quando cambiai scheda video passando da Ati ad Nvidia non ho più avuto a che fare con i driver per ATI, sono curioso però di sapere facendo un confronto tra le due marche come sono i driver proprietari per l’una e per l’altra. Quale secondo te in resa è migliore e più simile alla controparte windows? Se dovessi ad ora consigliare una scheda video tra le suddette marche in ambiente linux trascurando i driver closed, quali sceglieresti?

    Semplice curiosità…

    (il portatile di mio padre monta ATI e quindi ne avrò a che fare tra nn molto)

    • guarda fin’ora io tra i tanti pc che ho ed inoltre ho installato ad altri
      diciamo che secondo me le più compatibili con linux sono sicuramente le
      nvidia
      in questi ultimi anni comunque sembra che anche le ati comincino a dare meno
      problemi di driver anche se da quel che sento e per esperienza personale
      nvidia è migliore
      Inoltre ho sui miei pc ho come distribuzione Arch Linux Gnome / KDE / Xfce /
      Lxde – Ubuntu 11.10 e 11.04 Kubuntu 11.04 / 10.04 Debian Squeeze / Debian
      SID con Xfce / Fedora 15 Gnome e KDE / Paldo Linux / Gentoo e tra tutte
      queste disto con Nvidia non ci son problemi con ati hd5700 su Debian e
      Fedora ho avuto un po di problemi

      Il giorno 19 giugno 2011 10:38, Disqus
      ha scritto:

  • Perché complicarsi la vita? Basta scaricare il file .run per la propria architettura, spostarsi col terminale nella cartella dove si è scaricato suddetto file; da terminale: sudo sh ./ati-driver-installer-11-6-x86.x86_64.run (per i 64bit); lasciare tutto in automatico e alla fine, sempre da terminale, dare: sudo /usr/bin/aticonfig — initial
    Riavviare

    • hai ragione ma nelle versioni precedenti l’installazione su ubuntu dava problemi mentre se fatta da pacchetti no tutto qua era per migliorarne l’installazione

    • Lucaa

      per 32bit?

      • la versione è sia per 32 che 46 bit

        • Lucaa

          sul sito dice non sono disponibili driver linux per la mia HD AGP. come posso fare?

          • devi rimanere con quelli open presenti di default
            stessa cosa succede anche su un mio vecchio pc che go la 9200 pro
            purtroppo quando abbiamo schede grafiche datate ci son questi problemi

    • turista per caso

      geniale giorgio,geniale!!!invece che farti creare i deb e poi installarteli come fanno fare i miliardi di guide presenti online(e che tra l’altro mi fanno ricevere pure un errore)col tuo sitema due minuti di lavoro e liscio come l’olio….grazie milleeeeeeeeeeeeeeeeeee

  • niente da fare… i driver ATI mi odiano da sempre… sono riuscito a rimuoverli fortunatamente… perché l’unico risultato che sono riuscito ad ottenere è stata l’impossibilita di avviare gnome shell… 

    • Doko

      Come bisogna fare per rimuoverli e tornare tutto alla situazione di partenza? E’ possibile avere i comandi da dare nel terminale? Grazie

      • ecco come ho fatto io:

        – ho avviato una console
        – per rimuovere i driver:sudo apt-get remove fglrx-amdcccle fglrx-kernel-$(uname -r) fglrx-kernel-source

        A questo punto ho dovuto reinstallare alcuni pacchetti, come indicato qui:
        http://wiki.ubuntu-it.org/Hardware/Video/Ati/Radeon

        Ho riavviato il sistema ed ho ritrovato la situazione precedente.

        Spero di esserti stato utile.

      • hai installato da pacchetti i da binario?

  • Antonio G. Perrotti

    ho fatto una specie di esperimento. ho customizzato elementary jupiter con uck rimuovendo tutti i pacchetti relativi a nvidia e dopo averlo installato non mi chiede i driver proprietari per la ati del mio portatile. mi sembra che funzioni meglio, e si avvia molto più veloce con plymouth bello pulito. da cosa può dipendere?

  • davidfra

    è da alcune versioni che provo ad installare i Driver Catalist su un portatile ASUS A6000 con scheda grafica Ati Mobility Radeon X1600 dato che dal sito Ati è sparito il riferimento di Asus come fornitore del driver… ma installandoli non posso accedere al CCC ne, ovviamente usare il 3D.
    C’è possibilità di risolvere?

    P.S. i driver open installati dal repository funzionano.

  • Luca Cavallaro

    Questa nuova versione come si comporta con Gnome3?

    • personalmente non lo so dato che sui pc dove ho gnome 3 ho nvidia
      in rete ho letto che sembra andare per il resto non so dirti altro

  • appassionato1969

    procedura provata su lucid, ora se vado in sistema>amministrazione>driver hardware me lo da attivo ma gli effetti compiz non funzionano.. come mai? grazie

    • questo non dipende dai driver ma se la scheda supporta compiz o meno
      che modello di scheda grafica hai?

No more articles