Da pochi giorni è disponibile il nuovo aggiornamento di Java 6.24, e LffL ha aggiornato il PPA Java dedicato aggiornando i pacchetti alla nuova versione 6.24.  Inoltre abbiamo preparato anche la nuova versione per la nuova Ubuntu 11.04 Natty quindi se volete testarla potete già installare Java all’ultima versione stabile disponibile.
Per conoscere le novità della nuova Java 6.24 basta consultare QUESTA pagina.
Per installare Java 6.24 su Ubuntu 11.04 Natty, 10.10 Maverick e 10.04 Lucid utilizzeremo i PPA LffL Java:

sudo add-apt-repository ppa:ferramroberto/java 
sudo apt-get update  
sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
se avere problemi nell’installazione potete segnalarlo commentando l’aricolo
  • marste

    Avendo Firefox 4 una volta installato e facendo un “verify now” dal sito java.com, non riconosce l’ultima versione, ma ancora la 6 update 20.

    • controlla in gestione componenti aggiuntivi – plugin cosa ti indica
      casomai prova a riavviare
      ho testato con f4 beta 11 e me lo trova senza problemi
      http://i.min.us/ilIdDc.jpeg
      fammi sapere

      • Stefano Marzorati

        A posto! Non avevo ancora rimosso IcedTea Java Plugin e OpenJDK Java 6 Runtime. Grazie mille

        • Ringhio_16

          quindi è normale che nel test,Java segnala come ultima versione la 1.6.20 in presenza di IcedTea Java Plugin e OpenJDK anche se aggiornato correttamente con la 1.6.24 e averla selezionata come alternativa?

          grazie

      • Stefano Marzorati

        Ma perchè digitanto: java -version mi compaiono ancora?
        java version “1.6.0_20”
        OpenJDK Runtime Environment (IcedTea6 1.9.5) (6b20-1.9.5-0ubuntu1)
        OpenJDK Server VM (build 19.0-b09, mixed mode)

        Non basta un: sudo apt-get remove openjdk-6-jre ?

        Grazie ancora

        • potevi anche lasciarlo
          da terminale
          dai
          sudo update-alternatives –config java

          e seleziona la 1.6.24
          questo sistema ti permette di utilizzare sia
          sun-java che openjdk
          fammi sapere

          • Stefano Marzorati

            Gentilissimo!

          • per quel che posso cerchiamo di aiutare un pò tutti
            se hai problemi non esitare a segnalarli
            ciao

      • Patris N

        Ciao! Stessa situazione di marste, ho installato dai tuoi repo l’ultima versione di java: il terminale me lo conferma e naturalmente ho impostato affiche si usi java di san piuttosto che l’implementazione open. Con FF 3.6 e crhomium il sito java mi dice che uso la versione x.20 e non la 24 come dovrebbe essere. In componenti aggiuntivi ho trovato però solo icedtea plugin alla versione 20. Eppure sun-java6-plugin è installato, ma non compare
        grazie e complimenti per il sito e il tuo lavoro

      • PatrisX

        ok, tutto bene, mi è bastato rimuovere IcedTea plugin

No more articles