Chi da poco ha installato la nuova Ubuntu 10.04 Lucid si sarà sicuramente accorto che sun-java6-jre non è disponibile nei repository.
Ecco quindi, in data odierna, come fare ad installare Java 6 Update 20 nella nostra K|X|Ubuntu 10.04 Lucid.

E’ DISPONIBILE LA NUOVA VERSIONE 6u21 PER INFORMAZIONI CONSULTARE QUESTO ARTICOLO

Per prima cosa se abbiamo installato openjdk (nel mio caso avendo installato ubuntu-restricted-extras l’aveva installato) occorre rimuoverlo per farlo avviamo il terminale e scriviamo:

sudo apt-get remove openjdk-6-jre

e poi

sudo apt-get autoremove

e confermiamo.

Ora sempre da terminale e scriviamo:

sudo add-apt-repository “deb http://archive.canonical.com/ lucid partner”  && sudo apt-get update &&  sudo apt-get install sun-java6-jre sun-java6-jdk sun-java6-plugin sun-java6-fonts

e confermiamo.

Durante l’installazione si aprirà questa immagine:

spostiamoci con il tab (il tasto sopra il bloc maiusc) fino a che apparirà selezionato di rosso la scritta OK e premiamo invio. Si aprirà questa schermata:

sempre con il tab (il tasto sopra il bloc maiusc) andiamo a selezionare di rosso la scritta SI e premiamo invio.
Ora dobbiamo aspettare che finisca l’installazione.

Al termine avremo il nostra Java sulla nostra K|X|Ubuntu 10.04 Lucid.

Se avete problemi, consigli alternative potete farlo commentando questo post.

  • Anonimo

    Girano voci in rete che non sarà oggi la data di rilascio della nuova LTS, causa un bug nel grub. Voi del blog sapete qualcosa in merito?

  • Anonimo

    ciao. ho fatto come hai scritto ma java non funziona
    🙁

  • in che senso non ti funziona Java?

  • Anonimo

    sono l'anonimo di prima.
    no, grazie funziona…bastava riavviare il sistema 😀

    grazie mille

  • puzzone

    non mi parte, non trova una class, qualcuno sà aiutarmi??

  • Ottima guida. Installata senza nessun problema.
    Grazie.
    Merlino88

  • Anonimo

    ECCELLENTI!:-) Grazie!!!

  • Ho seguito tutta la procedura, ha caricato tutto ma all'ultimo script mi risponde:

    giorgio@giorgio-desktop:~$ sun-java6-plugin sun-java6-fonts
    sun-java6-plugin: command not found

    come posso fare?

  • @giorgio
    devi dare

    sudo apt-get install sun-java6-plugin sun-java6-fonts

  • fatto. tutto OK. grazie

  • Ti ringrazio per l'aiuto!
    Ciao by memo

  • Perfetto!! Ha funzionato al primo colpo. Grazie 1000.
    Se puo' esser utile, permettimi di lasciare il link per verificare se l'installazione è andata a buon fine:

    http://www.java.com/en/download/help/testvm.xml?ff3

    Ancora grazie

  • Anonimo

    Magico!!! ha funzionato al primo colpo. complimenti Big@

  • salve!vorrei kiedervi una cosa…ho segiuto la procedura descritta qui e non ho avuto problemi…subito dopo ho anke installato eclipse,ma una volta aperto non lo riconosce java, mi da progetti generici e non mi fa creare "java-project" sapete come posso configurare la cosa??? help me please ke ho una marea di lavoro arretrato da sviluppare in java tramite eclipse!!!!

  • Simone

    root@simone-notebook:~# add-apt-repository "deb http://archive.canonical.com/lucid partner" && apt-get update && apt-get install sun-java6-jre sun-java6-jdk sun-java6-plugin sun-java6-fonts
    E: La riga 54 nel file /etc/apt/sources.list non è corretta (dist parse)

    Cosa devo fare?
    Help me pls!

  • fai cosi

    sudo gedit /etc/apt/sources.list

    si aprirà gedit vai all'ultima riga e correggila con

    deb http://archive.canonical.com/ lucid partner

    e salva

    dai
    sudo apt-get update

    e poi

    sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

    fammi sapere
    ciap

  • Toyman90

    ciao..ho avuto anche io il problema nella riga 54..sto cercando di fare quello che hai detto tu da gedit ma la sources.list è di sola lettura e non posso cambiare alcun parametro

  • @Toyman90

    devi avviare gedit da root per farlo dai

    sudo gedit /etc/apt/sources.list

    cosi la puoi modificare

    ciao

  • Anonimo

    a me si è piantato cosi:

    Configurazione di sun-java6-fonts (6.20dlj-1ubuntu3)…
    Updating fontconfig cache for /usr/share/fonts/truetype/ttf-lucida
    No CIDSupplement specified for Dotum-Bold, defaulting to 0.
    No CIDSupplement specified for Batang-Regular, defaulting to 0.
    No CIDSupplement specified for Batang-Bold, defaulting to 0.
    No CIDSupplement specified for Dotum-Regular, defaulting to 0.

    che si puo' fare' grazie vin

  • ~vin

    allora dai un

    sudo apt-get install -f

    se non risolve ropova anche con

    sudo apt-get -f install

    fammi sapere cial

  • Anonimo

    Grande..ora funza 😉

  • Anonimo

    Non mi viene installato java 🙁

    E: Impossibile impostare il blocco /var/lib/dpkg/lock – open (11: Risorsa temporaneamente non disponibile)
    E: Impossibile acquisire il blocco sulla directory di amministrazione (/var/lib/dpkg/). Un altro processo potrebbe tenerla occupata.

  • ~anonimo
    hai il sistema o in fase di aggiornamento, o stai installando altri pacchetti o hai synaptyc avviato

    riprova e vedrai che si installa
    ciao

  • Anonimo

    Ciao scusami ho un problema dovrei installare ajva senza avere una connessione ad internet (in realtà java mi serve proprio per poter attivare una connessione via proxy protetta da password che si avvia con java all'apertura del brower)ho provato ad installare il bin installabile dal sito di java ma non funziona, credo che manchi un qualche riferimento che colleghi java al browser. hai qualche consiglio?
    ps considera che ho un altro pc con windows col quale collegarmi per prelevare eventuali pacchetti o file

  • c'è un'applicazione apposita per scaricare i pacchetti per distribuzioni offline

    http://linuxfreedomforlive.blogspot.com/2010/06/keryx-0924-aggiornare-ubuntu-offline.html

    la puoi utilizzare anche su windows

    ciao

  • Anonimo

    Grande ! Avevo un'applicazione java che non funzionava correttamente e visualizzava a scatti. Ho seguito la guida e adesso va che è una meraviglia !

    Grazie.

    Francesco

  • Anonimo

    vorrei aggiornarela java 6u20 gia' installata alla 6u21 e successive dato che ho ubu 10.04 e lo aggiornero per 3 anni

  • ~anonimo
    tra un paio di giorni preparo un repository esclusivo per aver java sempre aggiornato (serve prevalentemente anche a me visto che lo utilizzo molto) è già pronto serve solo un paio di giorni che torni dalle ferie perché da qui non risce a caricare i 150mb su launchpad ( è un problema di fastweb e del suo ip del c…o) troverai un post con tutto detttagliato
    ciao

  • Anonimo

    OTTIMO, installato tutto e funziona perfettamente.
    Grazie
    Shadowline

No more articles