Chi da poco ha installato la nuova Ubuntu 10.04 Lucid si sarà sicuramente accorto che sun-java6-jre non è disponibile nei repository. Le alternative sono o installare openjdk oppure (come nel mio caso) cercare un’alternativa. Ecco quindi, in data odierna, come fare ad installare Java 6 Update 18 nella nostra K|X|Ubuntu 10.04 Lucid.

Per prima cosa se abbiamo installato openjdk (nel mio caso avendo installato ubuntu-restricted-extras l’aveva installato) occorre rimuoverlo per farlo avviamo il terminale e scriviamo:

sudo apt-get remove openjdk-6-jre

e poi

sudo apt-get autoremove

e confermiamo. Ora sempre da terminale e scriviamo:

sudo add-apt-repository “deb http://archive.canonical.com/ lucid partner”  && sudo apt-get update &&  sudo apt-get install sun-java6-jre sun-java6-jdk sun-java6-plugin sun-java6-fonts


e confermiamo.

Durante l’installazione si aprirà questa immagine:

spostiamoci con il tab (il tasto sopra il bloc maiusc) fino a che apparirà selezionato di rosso la scritta OK e premiamo invio. Si aprirà questa schermata:

sempre con il tab (il tasto sopra il bloc maiusc) andiamo a selezionare di rosso la scritta SI e premiamo invio.
Ora dobbiamo aspettare che finisca l’installazione.

Al termine avremo il nostra Java sulla nostra K|X|Ubuntu 10.04 Lucid.
Testata su Kubuntu, Xubuntu e Ubuntu 10.04 Lucid Beta 1.
Se avete problemi, consigli alternative potete farlo commentando questo post.

  • La prima volta che installo java senza avere problemi,su karmic non ha mai funzionato…

  • su karmic ti dava problemi!!!!
    strano prova a dirmi che problemi ti dava

  • Anonimo

    Dio i benedica
    è da une settimana che son diventato pazzo per installare java, ho provato con l'eseguibile .bin sal sito sun seguito la guida ma niente, openjdk è uno skifo
    oggi non ci volevo credere che era cosi semplice
    Grazie il tui blog è veramente Unico!
    Gennaro

  • Dopo aver aggiornato firefox dalla versione 3.58 alla versione 3.6 tramite ubuntuzilla,non mi funziona più java sun ubuntu 9.10 32 bit come potrei fare ?

  • prova a vedere se sun-java6-plugin è stato rimosso. PRova a reinstallarlo

    sudo apt-get install sun-java6-plugin

    e vedi se va

    fammi sapere
    ciao

  • Anonimo

    Finalmente sono riuscito ad installare java. Grazie tommaso

  • Anonimo

    io ho installato ma non mi appare sui componenti aggiuntivi e poi mentre facevo l'installazione è uscito un crash di gnome power manager..

  • riavvia e connettiti a dai sudo apt-get install -f

    fammi sapere

  • Non so se sono stati aggiunti da poco, però io ho installato java dai repository ufficiali abilitando i repository canonical.
    Ho aggiunto i repository launchpad che hai citato, però la versione che è presente li è meno aggiornata di quella presente nei repo ufficiali.
    Qui di seguito ti riporto l'output di apt dal quale puoi vedere da dove scarica i singoli pacchetti:

    Scaricare:1 http://it.archive.ubuntu.com/ubuntu/ lucid/main java-common 0.34 [80,3kB]
    Scaricare:2 http://it.archive.ubuntu.com/ubuntu/ lucid/main odbcinst 2.2.11-21 [34,8kB]
    Scaricare:3 http://archive.canonical.com/ubuntu/ lucid/partner sun-java6-jre 6.19-0ubuntu3 [6409kB]
    Scaricare:4 http://it.archive.ubuntu.com/ubuntu/ lucid/main odbcinst1debian1 2.2.11-21 [62,3kB]
    Scaricare:5 http://it.archive.ubuntu.com/ubuntu/ lucid/main unixodbc 2.2.11-21 [201kB]
    Scaricare:6 http://it.archive.ubuntu.com/ubuntu/ lucid/main gsfonts-x11 0.21 [10,5kB]
    Scaricare:7 http://archive.canonical.com/ubuntu/ lucid/partner sun-java6-bin 6.19-0ubuntu3 [29,4MB]
    Scaricare:8 http://archive.canonical.com/ubuntu/ lucid/partner sun-java6-jdk 6.19-0ubuntu3 [20,7MB]
    Scaricare:9 http://archive.canonical.com/ubuntu/ lucid/partner sun-java6-plugin 6.19-0ubuntu3 [1844B]

  • saranno aggiunti da pochi giorni perché fino a l 3 aprile non andavano
    il post è stato messo per chi come me utilizza java e non openjdk e con lucid se non erano disponibili in qualche maniera siamo riusciti ad installarli.

    Aspetto una settimana se i repo ufficiali non danno problemi sostituisco la guida con i repo ufficiali

    Grazie per la segnalazione

  • Purtroppo a me dice:

    Il pacchetto sun-java6-jre non ha versioni disponibili, ma è nominato da un altro
    pacchetto. Questo può significare che il pacchetto è mancante, è obsoleto
    oppure è disponibile solo all'interno di un'altra sorgente
    E: Il pacchetto sun-java6-jre non ha candidati da installare

  • @ Viltgance

    io oggi lo installato facendo:

    sudo add-apt-repository "deb http://archive.canonical.com/ lucid partner" && sudo apt-get update && sudo apt-get install sun-java6-jre sun-java6-jdk sun-java6-plugin sun-java6-fonts

    Fammi Sapere

No more articles