Nvidia 304.37 su Ubuntu 12.04:

Ad appena 10 giorni dal precedente rilascio nVidia ha rilasciato o nuovi Linux Display Driver 304.37 che portano il supporto per nuove GPU oltre ad integrare nuove migliorie.
Nvidia 304.37 aggiunge il supporto per le GPU GeForce GTX 680M, Quadro K1000M, Quadro K2000M, e Tesla K10,
Tra le novità del nuovo nVidia Linux Display Driver 304.37 troviamo delle correzioni e miglioramenti rigurado x.org e RandR, finalmente è stato definitivamente corretto il problema dello schermo blu quando veniva utilizzata l’accelerazione hardware come ad esempio su Flash Player.
Nvidia 304.37 migliora anche il tool per disattivare i driver nouveau durante l’installazione dei driver proprietari il tutto per impedire conflitti durante l’avvio del nuovo driver.

Aggiunto e migliorato il supporto per X.Org Server 1.13, gli sviluppatori nVidia hanno apportato diverse correzioni sulla gestione EDID e FXAA e introdotto il supporto per dispositivi con DisplayPort 1.2, che permette per schermi multipli di essere concatenati da un singolo connettore DisplayPort.

In questa pagina troverete il changelog completo dei nuovi nVidia Linux Display Driver 304.37.

Per installare i nuovi driver Nvidia 304.37 su Ubuntu 12.04:

sudo apt-add-repository ppa:xorg-edgers/ppa

sudo apt-get update

sudo apt-get install nvidia-current nvidia-settings

sudo apt-add-repository -r ppa:xorg-edgers/ppa

Al termine riavviamo.
Se al riavvio non parte il desktop manager LightDm o Ubuntu ma si avvia la shell con indicato di effettuare il login; basta successivamente digitare da terminale:

sudo apt-get install -f

sudo reboot

Ed al riavvio avremo il driver correttamente funzionante.

  • Gio

    ottima cosa, procedo subito.

  • perfetto tutto funziona! con kernel 3.5.1

    • però abilitando FXAA … le icone della Cairo Dock si vedono male, solo i contorni e semitrasparenti..

  • RobertoTrynight

    A me da errore l “X-config” e non posso settare la risoluzione!

  • Il problema dei video blu con accelerazione attiva continua ad esserci anche perchè non è un problema dei driver nvidia ma credo della libreria libvdpau. Installata la libreria patchata con il fix blue è tutto a posto:)

  • Per la libreria libvdpau1 per ubuntu
    sudo add-apt-repository ppa:tikhonov/misc
    sudo apt-get update
    sudo apt-get install libvdpau1

    In arch da https://aur.archlinux.org/packages.php?ID=59181

  • HaraldZimer

    funziona tutto perfettamente con il kernel 3.5.0-10, pure nei sistemi nvidia-optimus con il bumblebee 🙂

    • ottimo direi
      grazie 1000 per la segnalazione
      Il giorno 14/ago/2012 22:45, “Disqus” ha scritto:

  • fernando

    meglio installare quelli scaricati dal sito. Il ppa segnalato è molto instabile, leggendo sullo stesso le avvertenze si capisce perfettamente.

    • HaraldZimer

      esattamente dove si legge? so poco di inglese…..

  • M1rr0r92

    A me bubmlebee con questo aggiornamento non ha più funzionato, nel senso che se provo ad utilizzare la scheda Nvidia con optirun mi da il seguente errore:

    [ 119.250188] [ERROR]Cannot access secondary GPU – error: Could not load GPU driver

    [ 119.250231] [ERROR]Aborting because fallback start is disabled.

    Sto usando Ubuntu 12.04, con il kernel di serie 3.2.0-29, e i driver Nvidia aggiornato con il ppa xswat.
    Come potrei risolvere? Grazie in anticipo.

  • fernando

    per notizia il ppa x-update è ora aggiornato

No more articles