Di recente abbiamo realizzato una semplice guida per conoscere Debian nei suoi aspetti, tra questi la possibilità di installare driver proprietari delle nostre schede grafiche con molta facilità dato che sono presenti nei repository ufficiali.
In questo articolo parleremo dei Driver Nvidia presenti nei repository ufficiali e di come installarli con molta facilità grazie ad un semplice script. 
Particolarità dei Driver Nvidia su Debian è come vengono rilasciati come da etica, nella Distribuzione Stabile troveremo i Driver che hanno superato notevoli test e molte correzioni prima di arrivare alla versione Stabile, la versione presente è la 195.36.31. Mentre se abbiamo Debian Testing e SID avremo quasi sempre l’ultima versione stabile disponibile, in data odierna appunto la 280.13.

Per  installare i Driver Nvidia su Debian (6.0 Squeeze Stabile, 7.0 wheezy testing) utilizzeremo un semplice script basta da terminale digitare:

wget http://dl.dropbox.com/u/16585243/files/scripts/nvidia-installer-squeeze.sh
su
chmod +x nvidia-installer-squeeze.sh
 ./nvidia-installer-squeeze.sh

al termine riavviamo la nostra Distribuzione.

Al riavvio avremo i Driver Nvidia perfettamente installati nella nostra Distribuzione.

  • Aniello Luongo

    E per ati e intel ?

  • vaino sereno

    da repo

  • Joif

    ok perfetto, adesso però:
    1) ci dici a chi appartiene l’account dropbox dal qual scarichiamo lo script (è sicuro?);
    2) ci riporti il codice dello script, opportunamente commentato, spiegando cosa fa di preciso;
    altrimenti l’articolo così sembra un po’ incompleto (:

    • lo script è sul della fonte dell’articolo in caso che lo rimuova lo inserito anche nel mio account
      non serve riportare il codice lo scarichi e lo trascini dentro un editor di testo per visualizzarlo
      l’articolo è completo cosi com’è

  • dave

    su lmde mi sono ritrovato con l’impossibilità di far partire xorg. In fase di installazione mi ha attivato i repo squeeze, quindi penso abbia installato i driver 195.36.31, e poi voleva installare qualcosa come 6600 kb di roba

    • difatti lo script è per debian su lmxe aggiunge i repo debian che possono incasinare la distro

      • dave

        ottimo! motivo in più per tornare a mamma debian xD

  • masmas

    Ciao, ho effettuato due installazioni di wheezy su due diverse macchine: su quella più recente lo script ha funzionato subito e alla grande, sull’altra, più vecchia e con a bordo una FX5500, non c’è verso di installare i driver.
    Lo script mi genera un file xorg.conf che non mi avvia il server X, dopo che l’ho rimosso tutto torna a posto… ma senza driver.
    Nel frattempo ho smarrito pure il xorg.conf originale, ma questo è il male minore.
    Qualche idea?

    • avvia da ripristino e da root dai
      nvidia-xconfig
      riavvia e vedrai che funziona

      • masmas

        Intanto grazie infinite per la risposta, ci speravo, ma in che senso avvio da ripristino?
        Intendi da cd?

        • no al boot avvii il kernel sotto a quello che avvii di solito ci deve essere una dicitura resume o una cosa simile ora non ricordo bene ad un serto punto ti chiede di inserire la password di root o cliccare su Ctrl+D per proseguire il boot normalmente
          li inserisci la password e poi il comando

          nvidia-xconfig

          al termine digiti
          reboot

          cosi riavvii il sistema e vedrai che dovrebbe andare
          fammi sapere

          • masmas

            Di nuovo grazie infinite.
            Ora vado a letto che tra quattro ore ho la sveglia, domani provo. Se tutto va bene torno anche solo per conferma, altrimenti non volermene se ti chiedo di nuovo aiuto.
            Buonanotte.

          • masmas

            Niente da fare, purtroppo.
            Mi dice che non trova il modulo per il kernel, che non trova il driver, lo schermo… insomma non trova niente.
            Quindi mi chiede di loggarmi per accedere senza server grafico.
            Rimuovo il file xorg.conf e posso riavviare normalmente, ma ovviamente senza i driver nvidia.
            In fin dei conti posso sopravvivere senza, però mi sarebbe piaciuto capire, sennò perché usare linux…

          • ma hai dato il comando da root?

          • Massi Li

            Ciao, si ho dato il comando dopo essermi loggato root, ha eseguito e mi ha restituito il messaggio in cui diceva che era stata creata una copia di backup di xorg.conf.
            Ho riavviato con reboot ma la situazione non è cambiata, login testuale.
            Ho provato anche a dare startx ma mi restituisce i messaggi di cui al messaggio precedente.
            Comunque su questa macchina ormai ho installato una linux mint, certo più pesante ma funziona.
            Di nuovo grazie infinite per l’aiuto, io continuo a studiarmi debian sull’altra macchina (la principale) dove gira meravigliosamente.
            Ciao.

  • Ferik

    Dopo aver installato i nuovi drivers, tramite questo script su Debian Wheezy, non partiva più Xorg nemmeno col comando “startx” e nemmeno riconfigurandolo con “nvidia-xconfig”.

    Purtroppo il sistema è vecchiotto (AthlonXP e GeForce 6200) e sulla Debian Wheezy devo installare per forza il kernel 3.0.0.1-486 al posto del 686 per far girare i drivers Nvidia.

    Da “schermo nero” mi sono loggato come utente e poi come root (SU e password) e ho disinstallato tutti i pacchetti nvidia:

    apt-get remove nvidia*

    quindi ho reinstallato i vecchi drivers 275.28 (quelli che passa il convento) con il seguente comando:

    apt-get install nvidia-glx nvidia-settings nvidia-xconfig linux-headers-486

    finita l’installazione, ho dato il comando “nvidia-xconfig” e ho riavviato “reboot” ed è tornato a funzionare.

    Ciao 🙂

  • capo

    ma se uno ha wheezy, la guida va bene lo stesso o bisogna cambiare il comando con il nome della distribuzione?

  • Rosario

    Ciao,
    riusciresti a ripristinare il link per scaricare lo script.

    Grazie 1000

No more articles