lffl consiglia

Articoli Recenti

08 gennaio 2013

Steam e il problema di Flash Player in Ubuntu 64 Bit

-
Steam per Linux

Steam per Linux ha portato nel sistema operativo libero numerosi nuovi game e sta facendo avvicinare molti nuovi utenti stanchi di utilizzare Microsoft Windows.
Attualmente Steam viene rilasciato per Ubuntu nella versione beta la quale è già comunque abbastanza stabile e reattiva anche grazie alle tante correzioni e modifiche introdotte grazie alla segnalazione di bug dei primi beta tester e le varie migliorie approdate nei driver  proprietari per le schede grafiche.
Steam per Linux richiede per alcuni giochi Flash Player, tra le dipendenze richieste dalla piattaforma di Valve troviamo anche il plugin di Adobe Flash Player il quale però sta dando alcuni problemi sopratutto per gli utenti con Ubuntu o altre distribuzioni Linux 64 bit.
Difatti anche se installato correttamente Flash Player tramite repository ufficiali Steam ci segnala che non è presente nessun plugin nella nostra Distribuzione. Questo accade sopratutto se non abbiamo Firefox preinstallato e abbiamo una distribuzione 64 bit.

Per risolvere questo problema basta scaricare Flash Player nella versione tar.gz (non rpm o deb) per 64 Bit  dal portale ufficiale di Adobe.
Estraiamo il file tar.gz e spostiamo il file libflashplayer.so nella home e digitiamo da terminale:

mv libflashplayer.so ~/.local/share/Steam/ubuntu12_32/plug-ins/libflashplayer.so

chmod +x ~/.local/share/Steam/ubuntu12_32/plug-ins/libflashplayer.so

avviamo Steam e dovremo avere correttamente riconosciuto Flash Player se ci da ancora errore diamo da terminale:

cp ~/.local/share/Steam/ubuntu12_32/plug-ins/libflashplayer.so ~/.local/share/Steam/ubuntu12_32/plugins

e installare il pacchetto libxext:i386 per farlo basta digitare da terminale:

sudo apt-get install libxext:i386

e riavviamo.

Ringrazio Domenico P. per la segnalazione e Andrew di webupd8 per la correzione dell'articolo.